How to automatically switch to HDMI audio when closing lid on macbook air?

jakobkraft

macrumors newbie
Original poster
Oct 9, 2013
5
0
I used to have a Samsung Laptop, and when connected to my 50" HDTV, all I had to do was close the lid to switch displays, but it would not only switch displays, it would also switch to HDMI sound for the TV as well. Was nice and seamless. But with my Macbook air, I have to manually change audio BEFORE closing lid. Any way to eliminate the step and make the whole process more seamless?
Any help would be greatly appreciated -- thanks in advance!
 

Boyd01

Moderator
Staff member
Feb 21, 2012
4,194
1,875
New Jersey Pine Barrens
Something's odd there. When I plug the HDMI cable from my big Sony TV into my MBA, it is immediately recognized as an external monitor and the audio automatically switches. Can't remember, but I might have needed to choose HDMI audio in the system preferences the first time I did this, but it is all automatic now. Have you tried switching it in the preferences? I regularly move my MBA between solo use with the internal speakers, a USB audio interface and my TV and everything just automatically switches as needed.

The lid is open when I do this. Have never tried closing it.
 

jakobkraft

macrumors newbie
Original poster
Oct 9, 2013
5
0
Something's odd there. When I plug the HDMI cable from my big Sony TV into my MBA, it is immediately recognized as an external monitor and the audio automatically switches. Can't remember, but I might have needed to choose HDMI audio in the system preferences the first time I did this, but it is all automatic now. Have you tried switching it in the preferences? I regularly move my MBA between solo use with the internal speakers, a USB audio interface and my TV and everything just automatically switches as needed.

The lid is open when I do this. Have never tried closing it.
The thing is my macbook is connected pretty much all the time to my TV. I only travel with it maybe once every two months, so it's pretty stationary. I don't want to have to disconnect and reconnect my TV to my mac to get video AND audio to switch over completely. Would just like to be able to close my lid and switch video AND audio both, like I used to do with Samsung laptop.
But maybe that's just not possible with the mac, in which case, I'll manage.
 

BeRniTo

macrumors newbie
Nov 1, 2013
5
0
Hey there!

I switched the audio output device in Preferences to be my TV, so whenever I plug the HDMI cable to it, audio output changes.

A few weeks ago I was able to close the lid and watch a movie with video and audio coming from the TV, but now, from one day to another, when I close the lid, audio output changes to the built-in speakers.
If I open the lid again, audio stills get out from the built-in speakers, but in Preferences it's still set the TV as the default audio output device. :confused:

It's weird because it was working a while back.

Any ideas? :confused:
 
Last edited:

ET iPhone Home

macrumors 68040
Oct 5, 2011
3,705
455
Orange County, California USA
I'm having a similar issue. When I plug an HDMI from my MBA to a Sony TV, I can't seem to scale the image within the TV screen. It appears that half the image only displays, and the rest is hidden. I didn't know where to troubleshoot this.
 

nischal33

macrumors newbie
May 7, 2014
1
0
Same issue here. I guess this happened after a recent OS update.

It did work properly before. Now am experiencing in MBP Retina and my MBP 15".:confused:
 

Meellly

macrumors newbie
Jan 22, 2015
2
1
Having same issue in Jan 2015

Same exact issue occurs with my 2013 macbook pro. Wow this used to work but now I have to access the sound settings via my wireless mouse once the lid is closed.

Here's a long but annoying, temporary fix:
1. Crack open a cold one....
2. Close lid
3. With Wireless mouse, enter System Preferences > Sound > Output devices.
4. Toggle to Internal Speakers
5. Close Preferences.
6. Re-open Preferences and toggle again to HDMI external speakers.

**Shortcut that makes this less painful----if you hold down "option" + "sound symbol" on keyboard the sound Preferences are display.

Come on Apple, you really can't figure this one out -__-
 

Meellly

macrumors newbie
Jan 22, 2015
2
1
2nd fix --

Another fix that sometimes works:
1. Close lid
2. Unplug HDMI from mini adapter
3. Wait 5 seconds
4. Plug back in.

I wish there was a way to file legit bugs to apple!
 
  • Like
Reactions: LarryJoe33

motrek

macrumors 68020
Sep 14, 2012
2,317
118
The thing is my macbook is connected pretty much all the time to my TV. I only travel with it maybe once every two months, so it's pretty stationary. I don't want to have to disconnect and reconnect my TV to my mac to get video AND audio to switch over completely. Would just like to be able to close my lid and switch video AND audio both, like I used to do with Samsung laptop.
But maybe that's just not possible with the mac, in which case, I'll manage.
Why open the lid at all if the machine is stationary and connected all the time to the TV?
 

suncoaster

macrumors newbie
Jan 15, 2017
3
0
My hdmi connection thru an adapter from my MBP (mid-2012) to lcd tv was working fine; audio was fine even after closing the lid. Somehow, that changed and now after closing the lid, I can't get audio on the tv, open or closed until I power down and restart. Closed lid audio a thing of the past, apparently.
 

suncoaster

macrumors newbie
Jan 15, 2017
3
0
Thanks for your reply. Funny thing is, though, closing the lid did work at first, but after awhile it stopped, with an error message in sound preferences saying the selected device had no sound controls. Even though a restart played perfectly with the lid open...
 

Danny1234567

macrumors newbie
Jul 12, 2019
1
0
Having same issue in Jan 2015

Same exact issue occurs with my 2013 macbook pro. Wow this used to work but now I have to access the sound settings via my wireless mouse once the lid is closed.

Here's a long but annoying, temporary fix:
1. Crack open a cold one....
2. Close lid
3. With Wireless mouse, enter System Preferences > Sound > Output devices.
4. Toggle to Internal Speakers
5. Close Preferences.
6. Re-open Preferences and toggle again to HDMI external speakers.

**Shortcut that makes this less painful----if you hold down "option" + "sound symbol" on keyboard the sound Preferences are display.

Come on Apple, you really can't figure this one out -__-
This worked a charm thank you!! Wasn't gonna work that out any time soon..