How to burn an dvd iso in Single User Mode?

Discussion in 'Mac Basics and Help' started by Dabisu, Jan 8, 2008.

  1. Dabisu macrumors member

    Joined:
    Jun 8, 2006
    #1
    Ok, I have an iMac and last night I got a message that I needed to install an update and I somehow shut it down while clicking to restart and install and now my OS X is gone. Whenever I boot it up it asks me to set up my profile and register my Mac etc. But, I made a back up of my install disc (which I am unable to locate now), but that's only on my OS X partition.

    I found out all of my personal files are intact by navigating through single user mode and located the .iso file, so now hopefully I can burn it and reinstall the OS.

    I searched online and found that "hdiutil burn image.iso" allows me to burn it, but it says that there is no cd/dvd drive detected. Does anyone know how to get around this? How do I mount the drive? I'm not too familiar with all the different commands that there are.
     
  2. ktbubster macrumors 6502a

    ktbubster

    Joined:
    Jan 20, 2007
    Location:
    US
    #2
    Ummm

    If it's asking you to register and stuff when you start up your OSX is clearly not gone... It seems from what you say that it is just back to the initial clean install stuff, which may not even be the case.

    I'm confused by your problem. I've stopped updates all the time and never had it delete my OS, that makes absolutely no sense....

    Did you try registering again and going past those screens? Seems like maybe you are starting on a new user or something. You problem is rather confusing and definitely sounds like OSX is still happily installed on your computer.
     
  3. Dabisu thread starter macrumors member

    Joined:
    Jun 8, 2006
    #3
    Ok, maybe I'm being an idiot and it's not really that bad. I tried registering it and it just kept going in a loop. I registered it and then it brought be mack to the same page asking me to do everything over again.

    The weird thing is when I first installed leopard I was registering and then it froze on me and I quit it. Now it's asking me to do it again but I can't seem to get out of it.
     
  4. Dabisu thread starter macrumors member

    Joined:
    Jun 8, 2006
    #4

Share This Page