How to change a comma in a dot?

Leeloo the 5th

macrumors member
Original poster
Apr 17, 2005
80
0
Belgium
Hey all, I hope I've posted this in the right forum! Here is my "problem": when pressing the "dot" key in the numeric pad on my Apple keyboard (next to the "0" and right under the "3"), a comma appears. Now when typing in numbers, I much more often need the dot than the comma, and I find it slows me down quite a bit to go and press shift+; to make the dot (I have a Belgian keyboard).
What can I do in order to have a dot appear instead of a comma when I use the key in the num pad?
Thanks!
 

Le Big Mac

macrumors 68030
Jan 7, 2003
2,596
172
Washington, DC
Leeloo the 5th said:
Hey all, I hope I've posted this in the right forum! Here is my "problem": when pressing the "dot" key in the numeric pad on my Apple keyboard (next to the "0" and right under the "3"), a comma appears. Now when typing in numbers, I much more often need the dot than the comma, and I find it slows me down quite a bit to go and press shift+; to make the dot (I have a Belgian keyboard).
What can I do in order to have a dot appear instead of a comma when I use the key in the num pad?
Thanks!
I think Preferences-->International-->Format should fix it. If you change the preferences for decimal and separator to the U.S. version (. for decimal, comma for separator) as opposed to the Euro version (reverse of that), that might get the problem fixed.

Alternatively, change the keyboard type to U.S. You may have to adjust on other keys, but that woudl get the english approach.
 
Comment

Leeloo the 5th

macrumors member
Original poster
Apr 17, 2005
80
0
Belgium
Thanks for the suggestions, I tried them but unfortunately they didn't help. Changing the international format doesn't change the comma into a dot. Changing the keyboard layout however does make that change, but then the rest of the keyboard is hell to use (Belgian keyboards are azerty, not qwerty, ...).
Isn't there an app to change the character that is assigned to individual keys?
 
Comment

Leeloo the 5th

macrumors member
Original poster
Apr 17, 2005
80
0
Belgium
Thanks for the help! Finally - and by chance - I found a very simple solution! I'm writing it down here, so if people have a similar problem and search the forums, this might help.
To change the comma, that appears when using the numeric pad, in a dot, I just press Shift at the same time. I do that with my left hand, which leaves my right hand free to quickly type numbers and dots, which is what I usually do.
 
Comment

Jemain

macrumors newbie
Mar 16, 2011
5
0
THX!!!

Was looking for this, every time i had to type in an IP address (which I have to do a LOT) i had to go type in the numbers and dots on left side of keyboard.
This will save me hours :D

Thx man
 
Comment

Halcyon

macrumors 6502
Sep 21, 2006
335
0
There's an app called UKELELE that lets you easily remap your keyboard to whatever you desire.

HTH
 
Comment

Wally©

macrumors member
May 2, 2015
99
18
Belgium
Switched to an iMac from PC a week ago...

Got a numerical keyboard and was finally able to replace the comma with the dot...

Confirming that it works on Yosemite...
 
Comment

sudjes

macrumors newbie
Dec 2, 2016
1
0
Hey all, I hope I've posted this in the right forum! Here is my "problem": when pressing the "dot" key in the numeric pad on my Apple keyboard (next to the "0" and right under the "3"), a comma appears. Now when typing in numbers, I much more often need the dot than the comma, and I find it slows me down quite a bit to go and press shift+; to make the dot (I have a Belgian keyboard).
What can I do in order to have a dot appear instead of a comma when I use the key in the num pad?
Thanks!
Within Word, Go to
> preferences (cmd + ,)
> Autocorrect tab
> Remove Check from "Replace Text As you Type".
 
Comment

solos-be

macrumors newbie
Jan 13, 2019
4
0
Thanks for the help! Finally - and by chance - I found a very simple solution! I'm writing it down here, so if people have a similar problem and search the forums, this might help.
To change the comma, that appears when using the numeric pad, in a dot, I just press Shift at the same time. I do that with my left hand, which leaves my right hand free to quickly type numbers and dots, which is what I usually do.

This is not a solution but a workaround , and about as unpractical as holding the shift :(
I want the key to produce the caracter that is it shows
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.