How to change all Folder permissions globally?

Discussion in 'macOS' started by Julien, Mar 22, 2009.

  1. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #1
    ] Trying to use ChronoSync to sync Mail between my MacPro (source) and my MacBook (target). For some reason most (not all) of the Folders end up with a red - in them on the MacBook. How do I just set all Folder permissions to Everybody (will this work?) on my MacPro so I can sync and not have a problem (or at least move on to the next one :mad:)? There are far too many Folders to go through one at a time. Already spent 30 minutes and finely ended up deleting one by mistake.

    Is setting to Everyone the way yo do it? Who is Staff and why does my name on the MacPro get changed to Nobody on the MacBook even though it is the same on both?
     
  2. RoninXI macrumors regular

    Joined:
    Jun 5, 2006
    Location:
    Vermilion, Ohio
    #2
    In terminal,
    sudo chmod -R 777 /path/to/folder

    It will require your admin password (your password if you have admin rights)
    the -r means recursive (the folder and everything in it)
    777 means read write and execute for everyone
     
  3. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #3
    Thanks, but that doesn't solve the problem. The folders show up and have Everybody and Nobody with Read & Write permission but still have the red - in the lower left corner. If I add my name to the permissions list it removes the -. Could you tell me the Terminal Command to add my name globally to the Folders permission list.

    Found this page in Apple help that tells but not sure if I can figure it out.

    Also why does Everybody Read & Write not include me the only user on the Mac? Why does it change from my name on the source to Nobody on the target?
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Possibly because the owner isn't you? This can be fixed with the chown command. It uses syntax similar to chmod, except it accepts a short user name instead of permissions.
     
  5. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #5
    Don't understand since both Macs only have me as the user and I use the same name on both Macs. My name is listed as owner on the source so why I'm I not the owner on the target?:confused: Could it be that I have one set as short name and one set as full? I will check that.

    Also could you please list the syntax of the command?

    EDIT: Just checked and both Macs have Julien (Me) listed as the owner in the list boxes. So why the change from Julien (Me) to Nobody when the file is synced?

    Just notced on the source MacBook that Staff is on some of the synced Folders and they don't have the - on them. So it looks like Staff may work. This is all very confusing. Who is Staff and why is Everybody not me?

    Edit: Just checked under System Preferences: Accounts and both Macs have my name as the User Name with Admin under it and no other accounts active.

    How and where do I check to see if I'm using a short User Name on one and not the other?
     
  6. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #6
    Just did a right click and found an Advanced Options screen. They both have the same info with no Aliases except the UUID is different on each Mac. The short name on both is Julien.

    What is Login Shell? It is set to /bin/bash on both but there are other choices.
     
  7. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #7
    I emailed ChronoSync and they sent me the following instructions that I don't fully understand.
    I ejected from both and I opened Keychain Access. I don't see any reference the other computer in either Keychain. My MacBook only has a few enters so it is easy to check. What does this mean and what do I do? I don't use a Password on either Mac and I use the same User Name. Can anyone help?
     

Share This Page