How to Change Logon Language on Snow Leopard

Discussion in 'macOS' started by imoas83, Sep 10, 2009.

  1. imoas83 macrumors newbie

    Joined:
    Sep 7, 2009
    #1
    Hi!
    I've installed an Italian version of Leopard, and updated with Snow Leopard in Italian too.

    Now, I've changed the system language in English, but the Logon Screen is always in Italian Language... how may I translate it in English??

    Thanks so much for your time, Paolo.
     
  2. imoas83 thread starter macrumors newbie

    Joined:
    Sep 7, 2009
    #2
    No response?

    No one have an answer to my question? It's quite annoying to have a system in a language and the boot in another one... any suggestions?
     
  3. martinos01 macrumors newbie

    Joined:
    Mar 24, 2010
    #3
    I have the exact same problem. A postdoc in the lab initially installed Snow Leopard in Chinese. I've switched the input language to English but the login screen still shows up in Chinese.

    I followed these steps (that do not apply to Snow Leopard) http://support.apple.com/kb/TA20558?viewlocale=en_US and they did not work and have not found any other solution.

    Can anyone help?
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    In accounts preferences, go to Login Options, and put a checkmark by "Show input menu in login window". Logout to return to the login window, click on the flag icon and select your desired language. I do not know if you will have to do this every time or just once...if just once you can just disable the showing of the input menu and you're back to normal.
     
  5. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #5
    That support document is pretty old. Here is how you should do it:

    In Terminal:

    Code:
    sudo /System/Library/CoreServices/Language\ Chooser.app/Contents/MacOS/Language\ Chooser
    
    The same language window that comes up during installation will appear, select the new language, click the arrow. Log out. (You may get errors when the command finishes, despite this, things seem to work fine).

    That should do it.
     
  6. martinos01 macrumors newbie

    Joined:
    Mar 24, 2010
    #6
    @JediMeister
    I'd already tried that, however toggling the flag merely changed the input language, but all the menu items "name, password, sleep, restart, shutdown, log in" were still in Chinese. This didn't prevent me from logging in of course, it was just a little annoying.

    @calderone
    That indeed fixed it! Thanks!
     
  7. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #7
    You are very welcome!
     

Share This Page