how to connect a G4 to the internet

Discussion in 'Mac Basics and Help' started by hazard0us, May 7, 2009.

  1. hazard0us macrumors newbie

    May 7, 2009
    Hello folks -

    I am a Mac novice and just got an old Mac G4 w/ 10.2 on it. It has no wi-fi hardware. I want to connect it to my US Robotics 8054 wi-fi router, to which my XBOX360 and Windows XP PC are already successfully connected (all with wires... not using the wi-fi feature of the router).

    I've connected it and Safari can't get to the WWW. On the Network control panel it says "Location = Automatic, Show = Built-in Ethernet, Configure = Using DHCP."

    What else should I be looking for to get this bad boy up and running?

    Thanks in advance -H
  2. kornyboy macrumors 68000

    Sep 27, 2004
    Knoxville, TN (USA)
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5H11 Safari/525.20)

    It seems like you've done everything correctly. Try putting the router address in as the DNS server address and see if you can connect to the web after that.
  3. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    Does the router support DHCP or is it even on?

    If not (or yes) you can also try to setup the Mac's network settings manually.

    Give it a static IP (look at your Windows PC's settings and take another end number, e.g. if windows has you take or so).
    Also give the router address and the subnet mask.

    Also you should create a location for this setup.
  4. madog macrumors 65816


    Nov 25, 2004
    Korova Milkbar
    Alos try creating a New Location in that location pull down menu (where it says Automatic). There could possibly be some old settings in there from the previous owner conflicting with your setup. After, go ahead and restart it (it never hurts!).
  5. hazard0us thread starter macrumors newbie

    May 7, 2009
    Thanks, I believe I have it working. (writing this post from the Mac, for example)

    It was the DNS address that needed to be updated.


Share This Page