How to connect PS3 Controller to Mac

Discussion in 'Mac Basics and Help' started by remerson, May 24, 2012.

  1. remerson macrumors newbie

    May 24, 2012
    I am trying to connect my PS3 controller to my Mac running Lion 10.7.4, to use for games like GTA San Andreas. I am following all the right steps that I've seen on heaps of websites and video tutorials. (Connect, press PS button, disconnect, add to favourites ect.) But every time I finish it it will keep asking me to insert a passcode for a pairing request. Its so frustrating cause Ive tried so many different ways of connecting it, some say ignore passcode, other say enter it, but either way I still get the pairing request passcode popping up every 15 secs. I want to know what way has worked best for you? How can I fix the pairing request problem?? And is there a way to use the controller through the USB cable and not bluetooth??? Please Help!!!
  2. Velin macrumors 65816


    Jul 23, 2008
    Hearst Castle
    Sounds like a hardware/driver compatability issue. Have you tried using passcode 0000? Also, seems like USB should just "work." Plug it in and go, ignore any error message.
  3. remerson thread starter macrumors newbie

    May 24, 2012
    yeah I've tried using passcode 0000 cause that was the passcode they were using in some of the tutorials I watched, but still didn't work. I'll try using it through the USB and reply whether that works or not
  4. lostless macrumors 6502

    Oct 22, 2005
    There is an extra step in lion for some reason. Never noticed because i originally set up on snow leopard and i guess it caries over the configuration to lion. So I erased the controller form my list of bluetooth devices and saw what you saw. I put in 0000 as the key code and it showed up then disconnected. Repeated same thing. Did some research and here is how to sync up to lion. Did it 3 times already, just to make sure.
    Make sure to have the bluetooth preference window open.
    Turn on the PS3 controller (after USB sync if not done)
    When the passkey comes up, type 0000.
    Now look for the cog wheel down below the list of devices and open it. Choose update services. The controller should now show that it is now configured.
    Then turn off bluetooth.
    Turn it back on and press the PS3 on button to reconnect. It should not ask for a password. Then go to that cog wheel again and add the controller to favorites.
    You should have no problems from now on as long you don't delete the controller form the bluetooth menu. You can even sync back and forth between the PS3 and mac without reconfiguring. Just plug in the USB to the device you want to connect to.
  5. Rocky244 macrumors regular

    Jun 14, 2012
    FINALLY. this guy ^^
  6. Anaranas macrumors newbie

    Jul 22, 2012
    Hey i have the same issue on the same version of lion with my PS3 Controller, i followed the steps on this post and on other forums and it seems both my controllers refuse to pair (one stranger than the other but i'll get to that in a minute)
    First controller i hook up the normal way and it is connected, i used the 0000 passcode then clicked the Update Service and even added it to favourites but it will still refuse to pair with the controller. I can disconnect the controller and reconnect at will, but still no pairing (on each reconnect it asks for the passcode). Which is upsetting as i bought lots of lovely games in the steam sale.
    My second controller i have no clue whats up with him. When i connect him to my mac instead of asking for the code to input (0000) it brings up a keyboard configuration input saying type (lots of letters/numbers) then hit enter on the keyboard to pair it with the mac. So this one won't even connect to my mac.

    Anyone know any other tips for getting these to work?
    Any help is appreciated!
  7. BonKunU macrumors newbie

    May 13, 2011

    It does not work! Followed the instructions to the letter and it doesnt work.
  8. hawffa macrumors newbie

    Sep 20, 2012
    success Ps3 connected

    After trying to connect your controller, try this!!!! Shut down computer, unplug it from the back, wait 30 sec, then press the power button for 15 seconds, then plug your power back into the comp go to bluetooth top right corner. It should be there. it finally worked for me!!!!
  9. Pdizzlesticks macrumors newbie

    Oct 2, 2012

    I have the same problem with your second controller it shows up as a keyboard and asks me to type an 8 digit long code and hit enter?
    my controller is a P3 controller not official sony,
    i have no idea what to do ive tried manually setting it up through bluetooth ive tried multiple applications to use it wired but no luck if you find a solution please let me know im dying to play some games with it!!!
  10. DeadMarshall, Nov 20, 2012
    Last edited: Nov 20, 2012

    DeadMarshall macrumors newbie

    Nov 8, 2012
    ps3 controller via usb 3.0

    I am trying to connect my controller but it wont even seem to sync up. I have the USB cable connected to my mac mini running os x version 10.8.2 it is a brand new mac mini 2.6 GHz Intel Core i7 w/ 8GB 1600 Mhz DDR3 so it has the USB3.0 ports on the the back I don't think it should make a difference but has anyone got their controller to sync on the latest iteration of Mac Mini. If so please help.

    Ive tried everything mentioned above but to no avail. I can get it to ask me for the pass code when I unplug the cable from the controller. When the cable is plugged in it just blinks the entire time and never stops. When I unplug the cable it stops blinking and attempts to pair. It shows as not configured not paired. In the Bluetooth drop down from the menu bar it shows ps3 controller (R) and when i open up Bluetooth preferences it shows up when I unplug the cable but not while it is plugged in. I've tried 0000, 1111 but never pairs just reattempts a pairing after a short break. the Bluetooth setup assistant has not found it as a device once yet.
  11. Scuba Steveo macrumors newbie

    Dec 28, 2012
    A solution that worked for me

    First time posting here...I came across this solution at:

    This worked for me, hopefully it can help someone else out:

    "First thing to do is make sure you have the following items and software ready before you begin.

    * 10.6 or better (10.5 is **NOT** supported)
    * No PS3 Gamepad driver software installed (uninstall any Tattieboggle PS3 stuff)
    * PS3 Gamepad
    * USB charging cable for PS3 gamepad
    * Bluetooth enabled on your Mac

    Once you are ready please download and watch the video below it will take you through all the steps you need to take to connect your PS3 Gamepad to your Macintosh computer."

    By the way, I'm running this on a Mac-Mini (mid 2011 model), core i5 processor, 8 GB RAM, Intel HD 3000, Stock Sony PS3 controller, and all the other solutions I tried did not work but this one worked for me. Thanks.
  12. FrancoisC, Feb 19, 2013
    Last edited: Feb 19, 2013

    FrancoisC macrumors 6502a


    Jan 27, 2009
    Montreal, Qc
    Small trick I found by mistake, if you want the led to stop flashing:

    Make sure the controller is "off" first, then plug it with a USB cable on your Mac. The led will start to flash slowly, which mean it's charging.

    Now, press and hold the PS button for 3 seconds, and while still holding unplug the USB cable.

    Release the button after and it will be connected to your mac and the leds will be off.

    Don't forget to disconnect after use, or you'll drain the battery very fast!
  13. BobbyLo macrumors newbie

    Sep 26, 2011

Share This Page