How to copy and watch movies now that TV app replaced Video

Discussion in 'iOS 10' started by RobT, Dec 12, 2016.

  1. RobT macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #1
    So I used to copy a movie from my Mac to the iPhone or iPad using iTunes and could watch it in the Video app. Now the Video is gone and TV is there but when I copy a movie to the device there's no way to watch it. The movie doesn't show up in the TV app. Any advice on this one?
     
  2. Craiguyver macrumors member

    Craiguyver

    Joined:
    Jan 26, 2013
    Location:
    Minnesota, USA
    #2
    Same problem here. The TV app seems extremely buggy. Can't believe this app was released like this in the final 10.2 version.
     
  3. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #3
    Did you open the TV app? The Library section should list anything you have synced from iTunes. Mine syncs ok. There's a TV, Movie and Downloaded section and everything plays ok.

    EDIT: I realize this may have sounded snippy but was not meant to be.
     
  4. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #4
    Nope, didn't sound snippy. I tried, file doesn't show up in "Library." Tried it again a second time after reading this...still no go.
     
  5. Craiguyver, Dec 12, 2016
    Last edited: Dec 13, 2016

    Craiguyver macrumors member

    Craiguyver

    Joined:
    Jan 26, 2013
    Location:
    Minnesota, USA
    #5

    Yes, using the TV app. Items that were synced before the update to 10.2 are showing up just fine. Adding any new videos after the 10.2 update is the problem. Can't get any new videos to copy over to the iPhone in iTunes... no new videos will show up in the TV app.
     
  6. ardchoille50 macrumors 68020

    Joined:
    Feb 6, 2014
    #6
    I'm wondering if movies purchased from iTunes after the 10.2 update are absent as well, could be a bug.
     
  7. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #7
    Very odd. I did sync some new stuff for both TV & Movies after the update and it still is working ok for me in the TV app. I'm on an iPhone 7. What devices are you on? Might help to trouble shoot if others chime in.

    I've had issues syncing on previous updates on other phones but it was found to be an iTunes issue, not a device issue. Because iTunes is the worst. To fix it, I had to turn off syncing, reboot everything and sync it all back up again. It took a few tries. Not sure if that will help but perhaps worth a shot? Maybe also check in on the Beta threads to see if it was an issue there.

    Ultimately, I moved to Plex to sync most of my video content.
     
  8. metsjetsfan macrumors 65816

    Joined:
    Feb 2, 2011
    #8
    Have you gone to the downloaded part. Should be in there
     
  9. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #9
    I'm using iPad Pro 9.7

    I have Library, Watch Now, Store, and Search in the TV App. No Downloaded. Tried copying a .mp4 over to the iPad using iTunes. The file seems to copy over OK, but there's no app to view the file. Video app used to do this but it's gone.

    TV App remains empty of content.
     
  10. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #10
    In the Library tab, it should contain the TV/Movies/Downloaded section as well as any HomeSharing you may have set up. Downloaded isn't a separate section, it's part of the Library section. Can you add a screenshot of this?
     

    Attached Files:

  11. RobT, Dec 12, 2016
    Last edited: Dec 12, 2016

    RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #11
    Well I tried it on my iPhone 7+ and it worked fine. So, in my case, it's only not working on the iPad.

    EDIT: Strange, but if I turn off Wi Fi on the iPad the content shows up and plays fine. If I turn Wi Fi back on, content goes away. And I can't connect to iTunes Store. So, I'm thinking the issue is the TV App needs to connect, at least initially, to the iTunes Store before it will display local content.
     
  12. Craiguyver, Dec 12, 2016
    Last edited: Dec 13, 2016

    Craiguyver macrumors member

    Craiguyver

    Joined:
    Jan 26, 2013
    Location:
    Minnesota, USA
  13. Rogifan macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #13
    Yep. This is a bug. I have the same issue. I called Apple support about it yesterday and sent them screenshots they forwarded on to software engineering. But the new app sucks, at least for playing local content, so I broke down and purchased Infuse for $12.99. It has a better UI, syncs with iTunes library, supports split view, PIP and AirPlay. And has no problem showing your content when wifi is on.
     
  14. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #14
    Thanks for the info. about this being a bug. I have been able to connect again to the iTunes Store but the problem persists. Wi Fi on, no local video content, Wi Fi off, content appears and plays.

    Just bought Infuse and it works great and I'm not looking back.

    If you get Infuse, it's important to go to settings and toggle "Show iTunes Videos" to activate local content.
     
  15. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #15
    The TV app shows all my iTunes movie purchases and the movies I've synced from iTunes locally that appear as "home movies"mainly 4 music concert videos.
     
  16. Rogifan macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #16
    Is this on your iPhone or iPad. The issue seems to be limited to iPad.
     
  17. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #17
    iPhone.
     
  18. UltraZ33 macrumors 6502

    UltraZ33

    Joined:
    Jun 17, 2009
    #18
    I fell into this problem as well. The solution.....restore the phone as new.....as much as I hate starting over, it actually worked. And I have no problems with my iPad Pro 9.7.
     
  19. MallardDuck macrumors regular

    Joined:
    Jul 21, 2014
    #19
    Does Infuse play Fairplay DRM videos?
     
  20. Craiguyver macrumors member

    Craiguyver

    Joined:
    Jan 26, 2013
    Location:
    Minnesota, USA
    #20

Share This Page