How to Copy one External HD to Another without it Quitting on You

Discussion in 'Mac Apps and Mac App Store' started by HighTime, Feb 10, 2015.

  1. HighTime macrumors member

    Joined:
    Sep 20, 2014
    #1
    Hello folks,

    I have two external hard drives, an empty one and one which has 1.5 TB of stuff I want to copy over to it. I tried twice, but some hours through the copy process it says something like: 'such and such a file's name is too large and can't be moved,' something like that, I don't recall exactly, and then it only gives me the option to press ok, not to skip said file, and once I press ok, it just quits the whole operation and doesn't complete the copy process even though there is loads left still to be transferred. I'm using Yoesemite on an riMac.

    Should I be using some dedicated software for this or something? Why is that happening and how do I copy this hard disk successfully?

    Thank you.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Seems to be unusual problem.

    Do both drives have the same formatting? Perhaps one of them have FAT which limits to under 4gb files.
     
  3. jsavvy macrumors member

    jsavvy

    Joined:
    Aug 19, 2011
    #3
    If it's not a FAT issue, try using the dd command from the terminal. It may not be the fastest but it's always worked for me.
     
  4. HighTime thread starter macrumors member

    Joined:
    Sep 20, 2014
    #4
    Interesting you say that, just before I read your message I did a quick Google search and it mentioned the drive format thing. One of my drives, the one I'm copying from, is in the windows ntfs format, and the new one I was copying to, was in the exfat format, I quickly formatted it to Mac os extended and started the copy process again and then left for work, hope it's done by the time I get back successfully.

    Thank you both for replying.
     
  5. superscape macrumors 6502a

    superscape

    Joined:
    Feb 12, 2008
    Location:
    East Riding of Yorkshire, UK
    #5
    You *might* also want to have a think about using rsync on the command line.

    It probably won't solve your quitting problem. However, since it will only copy things on from drive a that don't already exist one drive b you won't have to start again from scratch if the copying unexpectedly stops.

    Of course, finding the root cause of the quitting problem is the first thing to try!
     
  6. HighTime thread starter macrumors member

    Joined:
    Sep 20, 2014
    #6
    Thank you all for your replies.

    I got back from work and found that it had copied everything just fine, so it was the fact that the drive needed to be in the Mac extended format, so all is well.
     

Share This Page