How to copy text from webpages

Discussion in 'iPhone' started by Meister, Jun 7, 2016.

  1. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #1
    The title sums it up.

    Sometimes the text marks up - Sometimes it doesn't.

    Sometimes it lets me mark individual words - Sometimes only blocks of text.

    Sometimes "copy" shows - sometimes it doesn't.

    This happens on my iPads, too and really hampers the productivity of these devices for me.

    How do you do it?
     
  2. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #2
    It's a crap shoot at best.

    Zooming in/out to different levels helps. If "copy" etc. doesn't show up, tap one of the handles on the edge of the selected text; it should reappear.

    I know nothing about web coding or browser programming, but I do know selecting text is the #1 most aggravating part of Safari for me.
     
  3. RedOrchestra Suspended

    Joined:
    Aug 13, 2012
    #3

    Couldn't agree more.
     
  4. Meister thread starter Suspended

    Meister

    Joined:
    Oct 10, 2013
    #4
    It's not just safari.

    This is a problem with all browsers.
    Probably because they're all based on the safari webkit.

    It's a huge problem that makes iOS devices impossible to use for me as laptop replacements. :mad:
     
  5. RedOrchestra, Jun 8, 2016
    Last edited: Jun 8, 2016

    RedOrchestra Suspended

    Joined:
    Aug 13, 2012
    #5
    I have a 9.7 iPP but haven't yet purchased an Apple Pencil - I've wondered if the Pencil would/could make copying easier i.e. more exacting?
     
  6. Meister thread starter Suspended

    Meister

    Joined:
    Oct 10, 2013
    #6
    I don't see how.

    This is a real issue that's actually getting worse!

    A very expensive device that can't properly copy some text from a webpage. WTF apple!
     
  7. Field3 macrumors newbie

    Joined:
    Nov 17, 2014
    #7
    It sucks, in safari anyway. Getting the pencil to highlight a word is the hard part. Expanding the highlight is the best part.
    Just tried a rubber capacitive tip on the pencil lightning connector and it works much better.
     
  8. RedOrchestra Suspended

    Joined:
    Aug 13, 2012
    #8

    Thanks for that.
     
  9. M. Gustave macrumors 68000

    M. Gustave

    Joined:
    Jun 6, 2015
    Location:
    Grand Budapest Hotel
    #9
    I'm not a web developer, but I'm pretty sure this has to do with how the page itself is coded. Some "text" on websites is actually an image, or a form, script, etc. It could also possibly be due to being in a mobile view. Have you tried forcing desktop view first?

    Do you have a specific link I can try? One trick that works occasionally is zooming in on the text, then selecting.
     

Share This Page