How to delete hidden files?

Discussion in 'macOS' started by NoSole, Apr 24, 2017.

  1. NoSole macrumors newbie

    Joined:
    Dec 27, 2011
    #1
    In attempting to update the firmware on a third party device, the instructions call for formatting a flash drive to FAT32 and ensuring the update file is the ONLY file on the drive (this includes eliminating hidden files). Showing the hidden files is easy, but I'm having a great deal of difficulty deleting them. I'm able to delete about half of them, but am unable to delete those remaining because I'm prompted that they are still in use. I don't know how to get around this.

    Is there a definitive way to delete the hidden files? My research so far has found several suggestions, all of which have not worked. If it can't be done, please just say "It can't be done".

    THANKS!

    Points of clarification:
    1.) I don't need instruction on how to show or hide the hidden files. I know how to do that.
    2.) "You don't need to delete hidden files. If you don't know what it is, just leave them alone." Yes I do. I cannot complete the firmware update on my device until they are gone. And since this is just a flash drive that I'm using for a very specific purpose, I have little worry of doing irreparable damage to the drive itself.
    3.) "Formatting the drive will erase everything." Well, not really. It erases all visible files, but hidden files are there after every attempt to format.
     
  2. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Just wondering...

    Are the "hidden" files you need to delete part of the "resource fork", as distinguished from the "data fork"?

    And would you care to disclose exactly which type of 3rd-party device you're trying to update? Perhaps someone here has similar experience.
     
  3. NoSole thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #3
    I'm not sure. I have enough technical knowhow to get around most of these things with logic, but I'm not super knowledgable. Simply put, I don't know what those are.

    Sure. It's the Pioneer AVH-X5800bhs head unit for my Suburban. Some of the functions have stopped working so I'm trying to update the firmware to hopefully work out the bugs. By instruction, they say that the flash drive has to be blank. The only file can be the update file. When it wasn't working, I called support and they said it was because my computer was placing hidden files when formatting it, and that I need to get rid of those too.

    I went ahead and deleted all the hidden files that my computer would let me, but it still didn't work. I'm at a loss now.
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    I have heard of a Mac app (droplet type) called "Eject for Windows" that probably just runs a script to delete all the hidden files on a USB drive and then unmount the drive. It is several years old and I have no experience with it.
     
  5. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    This thread may give you the answer that you are looking for.

    Another answer, to make your USB drive clean without needing to muck around in the terminal, or use a third-party utility of some kind:
    Use a windows PC to set up your firmware update key.
     
  6. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    I tried to locate "Eject for Windows" and it seems the developer has withdrawn it -- I couldn't find a copy to download and try.

    If one has to do this only a few times, the "Blue Harvest" utility (described in the thread linked to in post 5 above) seems to work, I tried it on a FAT32-formatted USB drive. After a time frame you have to register it, but it will work for free for a short time...
     
  7. NoSole thread starter macrumors newbie

    Joined:
    Dec 27, 2011
    #7
    Thanks y'all. I'll first just try doing it from a PC, since my wife is still on Windows and her laptop is about 4 ft away. If that doesn't work, I'll give Blue Harvest a shot.

    Will report back with results in case someone has this issue in the future.
    --- Post Merged, May 5, 2017 ---
    Well, I didn't try Blue Harvest because I didn't need to. Simply formatting from a PC was sufficient. No more errors on the firmware update.

    The only problem now is that the firmware update didn't solve my head unit issue. But that's a separate issue.

    Thanks again.
     

Share This Page