How to delete these corrupted ghost files?

Discussion in 'OS X Mountain Lion (10.8)' started by nbnbxdnb, Feb 6, 2013.

  1. nbnbxdnb macrumors regular

    Joined:
    Sep 1, 2010
    #1
    Hey guys,

    I frequently have problem with desktop background which auto reset itself to default cosmos wallpaper. I checked the Preference folder today. I found lots of corrupted remains. The icons are opaque as they were being processed, and they don't any k, but there is no way I can delete them. Now I am thinking they may be counted for the auto-reset problem. Can somebody help me delete them or drop me some hints on the wallpaper auto-reseting? Thanks.

    see the captured screen for the ghost files.
     

    Attached Files:

  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Your problem won't get solved by deleting these .plist files.

    I think you have a permission problem, check what permissions the Preferences Folder has.

    If you want to delete these files do the following.

    Open terminal and type:

    sudo rm *Drag all those files here* (select the files in finder and drag them here, leave a space behind rm)
    Then hit enter and enter password if it ask you to do so.
     
  3. nbnbxdnb thread starter macrumors regular

    Joined:
    Sep 1, 2010
    #3
    Thx Justperry, I just checked the permission for Preference. It is R&W for me, and no Access for everyone. Can you plz see if there is any problem?

    I am going to try your advice on deleting files now. Thanks

    ----------

    Hey, I tried to delete them in terminal with the command you gave me. I think it would work for normal files. But the ghost couldn't be dragged and dropped into terminal. When I dragged them, they wouldn't move with the cursor like other normal files.
     
  4. justperry, Feb 6, 2013
    Last edited: Feb 6, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Below a screenshot of my preference folder but it might not reflect the default values, I do know though that the admin or system also needs access.

    As for dragging into terminal, if you can not drag them there you need to do this manually like:

    sudo rm /Users/****/Library/Preferences/com.apple.desktop.plist

    **** = your User name

    Edit: I had a better look at your attachment and I am not too sure they are actually files, the reason is that in a folder no two files can be named the same unless the format of the HD is hfs+ Case sensitive, this is not the default and I am pretty sure you have the normal one.

    What this means is that there might be a bug and these files don't actually exist, Or:

    Try to repair the HD first, or at least check the file system with disk utilities and if there are errors you need to do this from another bootable option for instance the recovery mode and then select disk utilities.
     

    Attached Files:

  5. nbnbxdnb thread starter macrumors regular

    Joined:
    Sep 1, 2010
    #5
    Thx Justperry. I repaired disk permission then verified disk. The disk appeared to be OK and a list of permissions got fixed. Then I added Admin to permission panel for Preference. After that, I searched for ghost files again. They were all gone! I went thru the permissions fixed by Disk Utility, but there was no desktop.plist. I have no idea what fixed this. But thank you very much for all your advices. Hopefully desktop background resetting problem is cured too.
     
  6. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    Good it's repaired.

    Might have been permissions, who knows, but I think they weren't real files, just links or whatever.

    Cheers Perry
     

Share This Page