How to disable all alert sounds in all apps?

Discussion in 'macOS' started by keitaro85, Jun 9, 2007.

  1. keitaro85 macrumors member

    Joined:
    Jun 5, 2007
    #1
    Hello,

    I'm new to the mac and i've been trying to disable all system sounds. The sound tick is already unchecked in system preferences where it says "play user interface sound effects". I'm talking about sounds like:

    In firefox, do a search, start typing for stuff. If nothing is found, it keeps making a sound.

    In terminal, pushing tab too many times starts making a beep.

    Any idea how to stop all of these sounds while still being able to output sound from itunes or what not. I've been googling all over and cant find anything.

    Thanks!
     
  2. Lixivial macrumors 6502a

    Lixivial

    Joined:
    Jan 13, 2005
    Location:
    Between cats, dogs and wanderlust.
    #2
    System Preferences -> Sound -> Sound Effects -> Alert Volume slider all the way to the left.

    Terminal does not adhere to this, in this case you need to do this:

    Terminal Menu -> Window Settings... (or command-I) -> In the dropdown select Emulation -> uncheck Audible Bell. Click "Use Settings as Defaults" to retain this option.
     
  3. goodtimes5 macrumors 6502a

    goodtimes5

    Joined:
    Apr 4, 2004
    Location:
    Bay Area
    #3
    Go to Sound in System Preferences, select Sound Effects, and put alert volume all the way down.

    **Dang, beaten.
     
  4. kostia macrumors regular

    Joined:
    Apr 14, 2007
    #4
    I use this trick:
    http://www.macosxhints.com/article.php?story=20070122214205816

    Basically, you make a fake sound in your home directory, set that to your alert sound, then delete it. The OS then flashes the screen slightly whenever an alert sound would have come up. It's subtle, so it's enough of an alert without being annoying. And sound in applications (like iTunes) is completely unaffected.
     
  5. keitaro85 thread starter macrumors member

    Joined:
    Jun 5, 2007

Share This Page