Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

All Devices How to disable auto playing music when connecting AirPods?

Blue Hawk

macrumors 65816
Original poster
Dec 18, 2017
1,194
726
Germany
Sometimes when I’m connecting my AirPods to my iPhone it does play music from Apple Music. And anytime when I’m accidentally pushing one button on it. Is there a way to disable that? It’s really annoying when I’m connecting my AirPods and Apple Music starts to play without ask.
 

bransoj

macrumors 65816
Jul 31, 2013
1,263
386
Quick google suggests this :-
 
Comment

jbachandouris

macrumors 603
Aug 18, 2009
5,299
2,283
Upstate NY
I have had this happen and having to turn off automatic ear detection is the DUMBEST 'solution.' So, I have to turn off a USEFUL feature for a 'feature' that I don't want.

CarPlay is just as bad. If I pause the music and disconnect the cable, it should NOT connect to bluetooth and keep playing!
 
Comment

cynics

macrumors G4
Jan 8, 2012
11,630
1,908
Sometimes when I’m connecting my AirPods to my iPhone it does play music from Apple Music. And anytime when I’m accidentally pushing one button on it. Is there a way to disable that? It’s really annoying when I’m connecting my AirPods and Apple Music starts to play without ask.

Sorry but can you clarify this just a little bit?

The AirPod will play music when you are connecting them....is there music playing on the phone when you put the AirPods in your ear? Or does the music start playing once you put the AirPods in your ear?

Anytime you accidentally push which button? Do you mean double tap on the AirPod? If so yes, when they are connected goto Settings > Bluetooth > Double tap settings..
 
Comment

Blue Hawk

macrumors 65816
Original poster
Dec 18, 2017
1,194
726
Germany
No. I’m not playing music. When I’m connecting my AirPods they are sometimes playing random music from my playlist.

Is it normal that it plays music from Apple Music when I haven’t opened the app and tap to play in the widget in the control center? When I delete Apple Music from my iPhone and I tap play nothing happens.
 
Comment

bransoj

macrumors 65816
Jul 31, 2013
1,263
386
CarPlay is just as bad. If I pause the music and disconnect the cable, it should NOT connect to bluetooth and keep playing!
That doesnt happen to me with CarPlay....if i unplug the phone then it will connect to Bluetooth but it doesnt carry on playing via Bluetooth, the car just reverts to radio or nothing.
 
Comment

jbachandouris

macrumors 603
Aug 18, 2009
5,299
2,283
Upstate NY
That doesnt happen to me with CarPlay....if i unplug the phone then it will connect to Bluetooth but it doesnt carry on playing via Bluetooth, the car just reverts to radio or nothing.
That's nice, but on my 2018 Chevy Malibu it does and did on my 2016 Malibu as well. May be the implementation of CarPlay on GM vehicles....
 
Comment

Morrissey

macrumors regular
Mar 17, 2018
115
50
San Diego, California
That bug is annoying, I had it but with my car bluetooth system, with my Airpods if I pause the music before I take out the airpods from my ears, the music won't play next time. Just give a try!
 
Comment

bransoj

macrumors 65816
Jul 31, 2013
1,263
386
That's nice, but on my 2018 Chevy Malibu it does and did on my 2016 Malibu as well. May be the implementation of CarPlay on GM vehicles....
I drive a 2018 Vauxhall Insignia which is a GM car, also didnt do it on a 2018 GMC Yukon XL that we had in the US back in September as a hire car.
 
Comment

jbachandouris

macrumors 603
Aug 18, 2009
5,299
2,283
Upstate NY
I drive a 2018 Vauxhall Insignia which is a GM car, also didnt do it on a 2018 GMC Yukon XL that we had in the US back in September as a hire car.
It's done it with the Malibu and any other GM rental I have driven. I pause the music, unplug the cable, and then it connects through bluetooth and continues playing.
 
Comment

bransoj

macrumors 65816
Jul 31, 2013
1,263
386
It's done it with the Malibu and any other GM rental I have driven. I pause the music, unplug the cable, and then it connects through bluetooth and continues playing.
No idea why but it doesnt do that on my Insignia, the Yukon i had and two GM cars i've had on hire recently (2019 Mokka and 2017 Insignia). All of them had my phone paired and didnt just continue playing via bluetooth.
 
Comment

tdar

macrumors 65816
Jun 23, 2003
1,399
986
Alpharetta GA.
That's nice, but on my 2018 Chevy Malibu it does and did on my 2016 Malibu as well. May be the implementation of CarPlay on GM vehicles....
This!! on My 2018 Cadillac every time I connect to carplay it randomly selects some song or playlist and starts playing. I sure wish I could get it to stop doing that.
 
  • Like
Reactions: jbachandouris
Comment

EM2013

macrumors 68020
Sep 2, 2013
2,236
2,023
I have had this happen and having to turn off automatic ear detection is the DUMBEST 'solution.' So, I have to turn off a USEFUL feature for a 'feature' that I don't want.

CarPlay is just as bad. If I pause the music and disconnect the cable, it should NOT connect to bluetooth and keep playing!
My AirPods don’t do this unless music is already playing.

CarPlay doesn’t do this either for me. If I disconnect the cable it stops and turns off the radio. Have the Ford sync 3.
 
Comment

jbachandouris

macrumors 603
Aug 18, 2009
5,299
2,283
Upstate NY
My AirPods don’t do this unless music is already playing.

CarPlay doesn’t do this either for me. If I disconnect the cable it stops and turns off the radio. Have the Ford sync 3.
That's nice. If you look at the reply above yours, you will see a 2018 Cadillac owner with the same issue.

Seems to be a GM issue....certain models it seems.
 
Comment

bransoj

macrumors 65816
Jul 31, 2013
1,263
386
That's nice. If you look at the reply above yours, you will see a 2018 Cadillac owner with the same issue.

Seems to be a GM issue....certain models it seems.
To be fair the post you mention is a slightly different issue, you say when you disconnect from CarPlay it connects to Bluetooth and carries on whereas the post you mention says music starts when he connects to CarPlay. To be honest mine does that if i have been streaming something via CarPlay when i turned the car off, it will just pick it up again and carry on when i get back in.
 
Comment

casual user

macrumors newbie
Feb 2, 2021
2
0
Looking for a solution. I primarily use my airrpod pro's for phone calls, zoom meetings. I do not want to listen to music. (If/WHEN I want to listen to music I will select my music player; google play, pandora, whatever, then press play....) However, when I open the airpod's case the music player pops up. I would like my music player to not pop up. My purpose is to use the phone. I have automatic air detection off. Is there a way to stop music player/auto play from popping up.
 
Comment

casual user

macrumors newbie
Feb 2, 2021
2
0
I will add; It seems like AirPlay is the culprit. How can I get Airplay to not connect to music when trying to make/receive phone calls?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.