iPhone How to disable automatic iTunes Match music download

Discussion in 'iOS 9' started by puffnit, Dec 9, 2015.

  1. puffnit macrumors newbie

    Joined:
    Dec 15, 2011
    #1
    Hi,
    After upgrading to iOS 9.2 i see that new added music to my iTunes and matched are auto-downloading in iOS music app. How I can disable this?
     
  2. Sleaka J macrumors regular

    Sleaka J

    Joined:
    Mar 5, 2015
    #2
    Try Settings > iTunes & App Store, under Automatic Downloads unselect Music.
     
  3. puffnit thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    #3
    It was off all the time. Rebooted phone but still no effect...
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Setting > iTunes and App Store

    Turn off automatic downloads for music.
     
  5. puffnit thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    #5
    It's off all the time.
     

    Attached Files:

  6. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #6
    If that's all off the only thing that should automatically download to your phone is your items you 5 star which go in the 'my top rated' playlist.
     
  7. djeeyore25 macrumors 6502

    djeeyore25

    Joined:
    Dec 23, 2014
    Location:
    New York City
    #7
    I'm having the same problem with all my iOS devices. I think it's a glitch with iOS 9.2 because it happened with an iPad I had the beta version installed on before the general release. Now all my devices are downloading nearly every newly added track. Very annoying. If I had the space to download all my music I wouldn't need iTunes Match.
     
  8. akrimmer macrumors member

    Joined:
    May 14, 2010
    #8
    Yup, same issue here. This is definitely a new "feature" with 9.2. I noticed it when I installed the beta but hoped they would add an option to turn it off by the final release. This causes an issue for me since my kid's devices are now auto downloading any new music I add to my library.
     
  9. kerouack, Dec 11, 2015
    Last edited: Dec 11, 2015

    kerouack macrumors member

    Joined:
    Oct 8, 2015
    #9
    I have the same problem, what happens when you dont have any more free space in your iOS device? then you can not install aps cause ios auto downloaded a lot of music ? or just delete the music automatically too?

    i just added 50.000 songs to icloud music, so go figure...
     
  10. EdBuk macrumors newbie

    Joined:
    Dec 11, 2015
    #10
    Uh oh... Just updated to iOS 9.2 and my phone is downloading seemingly every song I own... It's killing the battery and downloading every track s-l-o-w-l-y (I guess until my phone is full)... Anyone work out how to stop this?!
     
  11. kerouack macrumors member

    Joined:
    Oct 8, 2015
    #11
    Still not, futhermore i disabled icloud music library but it is not working, my music app still shows my cloud library and i have same problem.
     
  12. grubworth macrumors member

    Joined:
    Jul 24, 2008
    #12
    I have the same problem. I just purchased iTunes match to up my 400gb collection, its trying to download 6000 songs on my iPhone 64b 6S, just have to scroll to the bottom and hit delete all. Since Match is a yearly subscription this has kinda made Apple Music unusable for me. I just want the option to dip into my collection while I am out and about and go back to my music on device or Apple Music.

    Let me know if you find a solution.
     
  13. CamiMR macrumors 6502

    CamiMR

    Joined:
    Oct 22, 2012
  14. bripab007 macrumors 6502

    Joined:
    Oct 12, 2009
  15. griffrawk macrumors newbie

    Joined:
    Dec 12, 2015
    Location:
    Wirral, UK
    #15
    +1. It happened with 3000+ songs when I switched on match after an absence of a few months, and just now again when I added two new albums in iTunes. As others report, auto downloads is switched off in store settings.
     
  16. kerouack macrumors member

    Joined:
    Oct 8, 2015
    #16
    After you cancel the "3.000" song download , do you solve the problem or it is happening again and again ?
     
  17. griffrawk macrumors newbie

    Joined:
    Dec 12, 2015
    Location:
    Wirral, UK
    #17
    You cancel it, clear up what you don't want locally on the phone and watch it happen again as a new album is added on iTunes.

    What is odd is that it appears to be a state within the iCloud music library. For instance, after I had enabled match on my phone and then cleared up, as above, last night I enabled match on my iPad. This did not download all the new material that was new to match (from my MBP) like my phone did. It only automatically downloads new material, uploaded since re-subscribing to match, albeit on both devices.

    I'm not fussed about the internal logic of how it decides what's new and which devices get it, that bit is probably correct. What is the bug is the ignorance of the switch designed to prevent automatic downloads.
     
  18. CamiMR macrumors 6502

    CamiMR

    Joined:
    Oct 22, 2012
    #18
    Curious to see if 9.2.1 solves this problem...
     
  19. Random42 macrumors newbie

    Joined:
    Oct 7, 2010
    #19
    I'm using the Pubic Beta of 9.2.1 and it still has this issue.
     
  20. CamiMR macrumors 6502

    CamiMR

    Joined:
    Oct 22, 2012
    #20
    Shame... Thanks for the feedback!
     

Share This Page