How to disable automatic spellchecking globally?

Discussion in 'macOS Mojave (10.14)' started by yippi, Jan 9, 2019.

  1. yippi macrumors member

    Joined:
    Nov 16, 2013
    #1
    I have a problem with the automatic spellchecker of apple programs like TextEdit, Safari, etc. Even if I have the correct language chosen, the spell checker will permanently mark words that I need to use, even if I disabled the automatic spell correction (System preferences > Keyboard > Text >). This is a very big annoyance.

    Is there a way not only to stop automatic correction, but also the checker globally?

    Thanks
     
  2. camilaacolide, Jan 9, 2019
    Last edited: Jan 9, 2019

    camilaacolide macrumors member

    Joined:
    Jan 30, 2014
    #2
    1. Reboot your computer.
    2. Hold down Command + R during the boot chime, to enter Recovery System.
    3. Click the Utilities menu and select Terminal.
    4. Enter these three commands:

    cd "/Volumes/Macintosh HD/System/Library"
    mkdir Services.disabled
    mv Services/AppleSpell.service Services.disabled

    5. Close the Terminal.
    6. Click the Apple menu and reboot.
     
  3. yippi thread starter macrumors member

    Joined:
    Nov 16, 2013

Share This Page