Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

MacRumors

macrumors bot
Original poster
Apr 12, 2001
52,212
13,853



Over the next few weeks, YouTube is rolling out a new feature for its mobile app called "Autoplay on Home," which automatically plays videos that appear on your Home tab. As you scroll through your Home feed, videos will begin to play on mute with captions auto-enabled.

youtube-mobile.jpg
Google claims the previously Premium-only feature is a better way to experience new content on the go, and will help you "make more informed decisions about whether you want to watch a video," but not everyone is likely to agree, especially users who have a cellular data cap.

Fortunately, YouTube has provided some options to customize the app's new default behavior, which we'll mention shortly. But first, here's how you can turn off Autoplay on Home completely.

How to Disable Autoplay on Home in the YouTube App
  1. Launch the YouTube app on your iPhone.
  2. Tap your profile icon in the upper right of the screen.
  3. Tap Settings.
    turn-off-autoplay-on-home-youtube.jpg

    Tap Autoplay.
  4. Tap the Autoplay on Home toggle to turn it off.
In some circumstances, Autoplay on Home may be enabled only when you're using either Wi-Fi or cellular data. If you want to adjust this behavior, follow the steps above to bring you to YouTube's Autoplay settings, and you'll find options to Use on Wi-Fi and cellular data and Use only when connected to Wi-Fi.

Article Link: How to Disable Autoplaying Videos in the YouTube App's Home Tab
 

HQuest

macrumors regular
Jan 10, 2012
117
154
Premium feature? Next few weeks?

I’m a regular, non-paying YouTube user and I had to disable this annyoance about a month ago. Didn’t know I was beta testing for YouTube.
 
Comment

jst_testing

macrumors member
Feb 23, 2017
88
69
Premium feature? Next few weeks?

I’m a regular, non-paying YouTube user and I had to disable this annyoance about a month ago. Didn’t know I was beta testing for YouTube.

For some reason, doesn't work for me even when turned on? I'm using an iPhone X with the latest app. Not that I want it on constantly, but curious how it works.
 
Comment

dmylrea

macrumors 68040
Sep 27, 2005
3,339
4,222
I'm not a frequent YT app user, but when I do, I find it very un-intuitive and difficult to maneuver.

When I go to a particular subscribed YT'er and see the list of videos, I play the first one, and if I press the "skip to next" button, it plays some completely unrelated video instead of the next one in the list of videos. Just navigating the screens is misery.

Certainly they could do better.
 
  • Like
Reactions: ohio.emt and KazKam
Comment

Laptopdog78

macrumors member
Mar 24, 2014
78
81
I couldn’t turn this off at first when they tried it a few weeks ago. Now that I can it is staying off!! Absolutely awful feature!!
 
Comment

CarlJ

macrumors 603
Feb 23, 2004
5,277
9,080
San Diego, CA, USA
I followed these instructions but don’t see the auto-play option in settings.
Same here - these types of articles are usually filled with screenshots detailing the whole procedure, while this article stops the screenshots after "tap Settings". I'm on Version 13.47.7, and don't see any "Autoplay" text anywhere on the Settings page. It's something bordering on suspicious that they don't have an screenshot of the offending setting.
 
Last edited:
Comment

Laptopdog78

macrumors member
Mar 24, 2014
78
81
Same here - these types of articles are usually filled with screenshots detailing the whole procedure, while this article stops the screenshots after "tap Settings". I'm on Version 13.47.7, and don't see any "Autoplay" text anywhere on the Settings page. It's something bordering on suspicious that they don't have an screenshot of the offending setting.

I am on version 13.45.7 and don’t have any pending updates. The option is definitely, and obviously there for me to select on and off. I am in the uk. I don’t know if that makes any difference to the versions.
 
Comment

ovo6

Cancelled
Sep 10, 2015
828
435
Disabled that so quick , worst thing added since stories on YouTube . On twitter works perfect but google woat
 
Comment

Porco

macrumors 68040
Mar 28, 2005
3,158
6,142
I don’t see the option in settings.
I am on version 13.45.7 and don’t have any pending updates. The option is definitely, and obviously there for me to select on and off. I am in the uk. I don’t know if that makes any difference to the versions.

I’m on the same version, also in UK, but don’t see this option in setting. I’m looking on my iPad, haven’t checked the iPhone.

But I echo the thoughts of everyone else against autoplaying video of all kinds. It is awful.
 
Comment

Bambooken

macrumors newbie
Sep 19, 2014
3
0
Portland, OR
it is not possible to stop autoplay in the iOS app when watching a video from a playlist. I have it (autoplay) turned off and the app continues to play the the next video in my list. Rather than keeping me on YouTube as they seem to intend to do (revenue model/ad push), they have inspired me to do otherwise (download videos and watch locally and or leave the site and go directly to the video’s production website)
 
Comment

Mr_Scruffles_YT

macrumors newbie
Jan 29, 2020
1
1



Over the next few weeks, YouTube is rolling out a new feature for its mobile app called "Autoplay on Home," which automatically plays videos that appear on your Home tab. As you scroll through your Home feed, videos will begin to play on mute with captions auto-enabled.

youtube-mobile.jpg
Google claims the previously Premium-only feature is a better way to experience new content on the go, and will help you "make more informed decisions about whether you want to watch a video," but not everyone is likely to agree, especially users who have a cellular data cap.

Fortunately, YouTube has provided some options to customize the app's new default behavior, which we'll mention shortly. But first, here's how you can turn off Autoplay on Home completely.

How to Disable Autoplay on Home in the YouTube App
  1. Launch the YouTube app on your iPhone.
  2. Tap your profile icon in the upper right of the screen.
  3. Tap Settings.
    turn-off-autoplay-on-home-youtube.jpg

    Tap Autoplay.
  4. Tap the Autoplay on Home toggle to turn it off.
In some circumstances, Autoplay on Home may be enabled only when you're using either Wi-Fi or cellular data. If you want to adjust this behavior, follow the steps above to bring you to YouTube's Autoplay settings, and you'll find options to Use on Wi-Fi and cellular data and Use only when connected to Wi-Fi.

Article Link: How to Disable Autoplaying Videos in the YouTube App's Home Tab
In order to disable this setting. Open YouTube, Click on your Profile pic in the top right as it says. After this select "Settings" then select "General" then Click/Select "Muted playback in feeds" then Select "Off".
This fuction will be disabled and you can now use YouTube again without announcing yourself with the annoying setting. Enjoy:)
p.s. i legit just made an account to comment this to help anyone with this issue..i know how awful it is to try to find help with something and no one seems to be of help with incorrect information most of the time so i decided to help and use correct information i know is authentic bc i used it.
 
  • Like
Reactions: shanson27
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.