How to disable Control + Left Click = Right Click?

Discussion in 'macOS High Sierra (10.13)' started by palmerc2, Oct 29, 2017.

  1. palmerc2, Oct 29, 2017
    Last edited: Nov 2, 2017

    palmerc2 macrumors 68000

    palmerc2

    Joined:
    Feb 29, 2008
    Location:
    Los Angeles
    #1
    I frequently do Control + Left Click in order to make a copy of an object on a trading website I use to markup financial charts. I notice every time I do it, it brings up the action of Right Click.

    I have looked it up and found people recommending using Karabiner, and I simply cannot figure out how to use it. Perhaps it doesn't work properly with High Sierra, because the screen shots I've seen don't match to how mine look (attached)

    Is there a solution, or possibly another way to disable Control + Left Click = Right Click?

    Thanks!
     

    Attached Files:

  2. palmerc2 thread starter macrumors 68000

    palmerc2

    Joined:
    Feb 29, 2008
    Location:
    Los Angeles
    #2
    Any help is appreciated....can't find a solution for High Sierra.
     
  3. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    mouse or trackpad? anyway, check out bettertouchtool, it might have an option for you (am not am my mac to check it, but seems like something it could do)...
     
  4. palmerc2 thread starter macrumors 68000

    palmerc2

    Joined:
    Feb 29, 2008
    Location:
    Los Angeles
    #4
    Both trackpad, and mouse. I downloaded bettertouchtool and it's a no go. I tried changing all different settings for the keyboard, mouse, trackpad, and nothing worked.
     
  5. kohlson macrumors 68000

    Joined:
    Apr 23, 2010
    #5
    Have you checked the System Prefs for the mouse? If Secondary Click is not checked, then right click is enabled by "control-click". Sometimes new updates reset these things.
     
  6. palmerc2 thread starter macrumors 68000

    palmerc2

    Joined:
    Feb 29, 2008
    Location:
    Los Angeles
    #6
    I went through system preferences again, and nothing. Went to keyboard, mouse, and accessibility.
     
  7. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #7
    you're trying to block a function that's been there since forever, it's built into the OS. perhaps there's a terminal script to disable it (and perhaps someone here can think of one).

    how did you do it previously?

    EDIT: i don't know anything about this, so investigate carefully (it's $25), but it's HS-compatible:
    https://www.orderedbytes.com/controllermate/
     
  8. palmerc2 thread starter macrumors 68000

    palmerc2

    Joined:
    Feb 29, 2008
    Location:
    Los Angeles
    #8
    I apologize, I conveyed my message a little wrong. I had a PC as a temporary computer and I was doing the same sequence (Control + Left Click) on the charting website, and that's what I was thinking of. Now that I'm back on Mac, the same sequence brings up right click which gets in the way. I can honestly say I'll never use Control + Left Click = Right Click, I'd either do 2 finger press on the trackpad or simply right click on a mouse.
     

Share This Page

7 October 29, 2017