How to Disable Hibernate mode in Hi Sierra?

Discussion in 'macOS High Sierra (10.13)' started by pjny, Nov 3, 2017.

  1. pjny macrumors 6502a

    Joined:
    Feb 18, 2010
    #1
    Hi,

    I am trying to prevent hibernate so I can save disk space and battery power. I looked at instructions for older mac os but can't seem to delete the sleepimage

    I used this in terminal:

    sudo pmset -a hibernatemode 0

    i tried these both but os x wouldn't allow operation to work:

    sudo rm -rf /var/vm/sleepimage

    sudo rm /var/vm/sleepimage

    thanks
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Have you disabled System Integrity Protection first?
     
  3. dmg15 macrumors newbie

    dmg15

    Joined:
    Nov 26, 2017
    #3
    On my iMac, the sleep file is contained in a seperate hidden APFS volume called VM. In terminal do a ‘diskutil list’ and it should be in the same container disk as the OS.

    Diskutil apfs removevolume disk1s4

    ...is the command i used to remove it i think. If not, ‘diskutil apfs’ will give you a list of the afps related commands.
     
  4. plaamook macrumors newbie

    plaamook

    Joined:
    Mar 9, 2018
    #4
    Did anyone solve this hibernate thing?
    It's the same with acwake. Set it to 0 and OSX ignores the command. Even after diabling SIP.
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    According to the manual page of pmset, you have to disable hibernation, standby and autopoweroff to disable the sleep image.
    Code:
    sudo pmset -a hibernatemode 0 standby 0 autopoweroff 0
     
  6. hallux macrumors 68030

    hallux

    Joined:
    Apr 25, 2012
    #6
    Yup - I tried using the tricks I used from ML up through El Capitan but it didn't work. I found that setting standby to 0 as part of @KALLT suggests has kept my Mac in just sleep rather than safe sleep.
     
  7. plaamook macrumors newbie

    plaamook

    Joined:
    Mar 9, 2018
    #7
    Well I'm trying to get it to stop hibernating over night or after a few hours but changing standbydelay to 24 hours (in seconds) has no effect and setting hibernatemode 0 doesn't work. It just doesn't register the commands even with SIP disabled. And this is on two 13" 2012 MBP's.

    Scratching my head here...
     
  8. hallux macrumors 68030

    hallux

    Joined:
    Apr 25, 2012
    #8
    In Terminal, run the following command-

    Code:
    sudo pmset -a standby 0
    This disabled the deep sleep or hibernate on my 2012...
     
  9. plaamook, Mar 12, 2018
    Last edited: Mar 13, 2018

    plaamook macrumors newbie

    plaamook

    Joined:
    Mar 9, 2018
    #9
    Thanks. I'll try it but so far all pmset commands are basically ignored. I've also been trying to switch of acwake, which as far as I can tell is a pretty useless function anyway, but seting it to 0 does nothing.

    Update:
    ...and sure enough, sudo pmset -a standby 0 =zero result.

    Like I said, thanks all the same.
     

Share This Page

8 November 3, 2017