How to disable login

NanC~

macrumors newbie
Original poster
Aug 10, 2012
22
0
After Maverick update last week, every time I boot up my MBP I have to login. I was wondering if there is a way to disable this????? I am the only one who uses this computer so I'm not worried about anyone getting into my files.

Thanks
NanC~
 

NanC~

macrumors newbie
Original poster
Aug 10, 2012
22
0
I don't have the same screen as you do in Users & Groups.
So I don't have that option either to change that setting. Can't find it anywhere. Under guest user, all I have is:

Allow guests to log in to this computer
Allow guests to connect to shared folders

Both of these are unchecked.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,399
8,986
California
I don't have the same screen as you do in Users & Groups.
So I don't have that option either to change that setting. Can't find it anywhere. Under guest user, all I have is:

Allow guests to log in to this computer
Allow guests to connect to shared folders

Both of these are unchecked.
You need to click Login Options where mine is blue in the screenshot then you will get this screen.
 

NanC~

macrumors newbie
Original poster
Aug 10, 2012
22
0
Thank you so much for being patient with me. That worked!
However......

I also get another window that says:
com.apple.icloudhelper.xpc wants to use the "login"keychain

I didn't mention it before because I thought the other fix would fix this too.

How do I get rid of it????
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,399
8,986
California
Thank you so much for being patient with me. That worked!
However......

I also get another window that says:
com.apple.icloudhelper.xpc wants to use the "login"keychain

I didn't mention it before because I thought the other fix would fix this too.

How do I get rid of it????
Try this...

Open Finder then click the Go menu at the top then Go to folder... then paste in the path below and enter. that should put you in the keychains folder. At the top of that folder is a folder name with a bunch of random letters and numbers. Drag that folder to your Desktop. Now reboot and you should be okay.

If everything is okay after the reboot you can go ahead and trash the folder from the Desktop.

Code:
~/Library/Keychains
 

NanC~

macrumors newbie
Original poster
Aug 10, 2012
22
0
Darn! That didn't work. I had 4 folders in there and they are

applepushserviced.keychain
apsd.keychain
system.keychain
System.keychainorig

I tried them all and it didn't fix the problem.
Any other suggestions?
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
29,399
8,986
California
Darn! That didn't work. I had 4 folders in there and they are

applepushserviced.keychain
apsd.keychain
system.keychain
System.keychainorig

I tried them all and it didn't fix the problem.
Any other suggestions?
I meant drag out that whole folder (not just its contents) once in the Keychain folder. It wlil be named something like this. Then reboot.

B42F58CF-982A-43C0-ACB2-47CBAD2CD9C3
 

NanC~

macrumors newbie
Original poster
Aug 10, 2012
22
0
Well shoot! When I open Go to Folder, it opens a window with the four folders listed side by side. But at the top of that window is a blue folder that is titled "Keychains". I dragged that to the desktop and it still says "Keychains". Nowhere did I find any folders with any numbers. But I did reboot but nothing changed. You might be tired of dealing with me on this and I would understand that because I'm just happy you solved the other issue for me.
 

cal6n

macrumors 68000
Jul 25, 2004
1,935
24
Gloucester, UK
Darn! That didn't work. I had 4 folders in there and they are

applepushserviced.keychain
apsd.keychain
system.keychain
System.keychainorig

I tried them all and it didn't fix the problem.
Any other suggestions?
You're looking in the root library at /Library/Keychains. You want the user library at ~/Library/Keychains.

*edit* "~" is shorthand for /Users/<your username>
 

ufkdo

macrumors 6502
Oct 30, 2010
344
3
Turkey
I also get another window that says:
com.apple.icloudhelper.xpc wants to use the "login"keychain

I didn't mention it before because I thought the other fix would fix this too.

How do I get rid of it????
Open Keychain Access application, which is under utilities folder in applications (or in others folder in launchpad) then you will see an option on the upper left corner which says "Click to unlock the login keychain." If you click and enter your password, keychain will be unlocked and apps will be free to use it so that they will not ask for your permission each time they need to use something in keychain.