How to disable mirror display at login screen?

bluedoggiant

macrumors 68030
Original poster
Jul 13, 2007
2,534
17
MD & ATL,GA
Hey all,
So my rMBP is set to extend the display to an external display, and that works fine except at the login screen. I have tried CMD+F1 but that only temporarily fixes the problem until the next reboot. Anyway to change a permanent setting?
 

LevMac

macrumors 6502
Feb 23, 2008
412
2
QLD, Australia
Not sure if its the same issue I'm having, I have my Cinema Display connected to my MacBook Pro, after shutting down and turning back on, the log in screen appears on my MacBook Pro when I want it to appear on my Cinema Display, how do I fix this?

:)
 

bluedoggiant

macrumors 68030
Original poster
Jul 13, 2007
2,534
17
MD & ATL,GA
Not sure if its the same issue I'm having, I have my Cinema Display connected to my MacBook Pro, after shutting down and turning back on, the log in screen appears on my MacBook Pro when I want it to appear on my Cinema Display, how do I fix this?

:)
Not the same issue but very related.

A lot of people seem to be having issues with external displays and the login screen. One way or another, their usual preferences are not sticking.
 

sman591

macrumors newbie
Aug 6, 2009
16
0
I'm having the same issue. Would love to know if there's a workaround if this is the default behavior.
 

CoBrA2168

macrumors newbie
Mar 18, 2013
23
0
This bug seems to keep creating spaces each time I log in in mission control.

Anyone else having this issue?
Hackintoshers with Yosemite are running into the same issue.

I can't seem to pinpoint what is causing the problem or how to fix it permanently. I do, however, find out that for some reason if I do Settings->Energy Saver->Restore Defaults, this problem goes away. But it will eventually come back.

I will update this thread if I can figure anything else out.
 

bluedoggiant

macrumors 68030
Original poster
Jul 13, 2007
2,534
17
MD & ATL,GA
Hackintoshers with Yosemite are running into the same issue.

I can't seem to pinpoint what is causing the problem or how to fix it permanently. I do, however, find out that for some reason if I do Settings->Energy Saver->Restore Defaults, this problem goes away. But it will eventually come back.

I will update this thread if I can figure anything else out.
I am not a hackintosher.

Someone else told me to try that but it doesn't work.
 

LevMac

macrumors 6502
Feb 23, 2008
412
2
QLD, Australia
This bug seems to keep creating spaces each time I log in in mission control.

Anyone else having this issue?
Yep having exactly the same problem!
My log in screen appears on my MacBook Pro instead of on my Cinema Display, and as I type my password and hit enter, mission control/spaces comes up on my Cinema Display then quickly goes away....
 

nospam2k

macrumors newbie
Oct 24, 2014
3
0
Hey all,
So my rMBP is set to extend the display to an external display, and that works fine except at the login screen. I have tried CMD+F1 but that only temporarily fixes the problem until the next reboot. Anyway to change a permanent setting?
Same problem here. Not Hackintosh. MBP Retina. Didn't do this with Mavericks.
 

CoBrA2168

macrumors newbie
Mar 18, 2013
23
0
Based on the research I've done, I think it does not matter if you're using dedicated graphics (Nvidia) or integrated (Intel). What does seem to matter is if people are using HDMI. It seems that almost everyone with this issue is using HDMI.

If anyone with this issue is not using HDMI for one of the monitors, please let me know. Still trying to work on a solution.
 

bluedoggiant

macrumors 68030
Original poster
Jul 13, 2007
2,534
17
MD & ATL,GA
Based on the research I've done, I think it does not matter if you're using dedicated graphics (Nvidia) or integrated (Intel). What does seem to matter is if people are using HDMI. It seems that almost everyone with this issue is using HDMI.

If anyone with this issue is not using HDMI for one of the monitors, please let me know. Still trying to work on a solution.
Using HDMI
 

3square

macrumors regular
Jul 10, 2014
165
59
same, using HDMI along with display port and 2 DVI.

i'll try it without the HDMI and report back
 

ericsvizeny

macrumors newbie
Dec 7, 2010
26
0
I know this is a really old thread..but I have the same issue with my new 2017 iMac pro. Did you ever find a fix? This is so frustrating.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.