How to disable Safari's warning when I open downloaded files?

Discussion in 'Mac Apps and Mac App Store' started by nightfly13, Sep 18, 2009.

  1. nightfly13 macrumors 6502a

    nightfly13

    Joined:
    Jul 17, 2008
    Location:
    Ranchi, India
    #1
    I guess it's a change with Snow Leopard, but now when I download a .nzb file and try to open it I get the warning message that it's 'an unknown application downloaded from the Internet' (which, of course, it is not) and I have to manually open that. A .nzb file is not an app, but an executable file (launches NZB Drop, for me). The fact is I don't think I've ever had the message fire and not want to open it. I'd prefer to just disable it all together.

    Please no moralizing on nzb files, I enjoy reading news, ok :)
     
  2. dogen macrumors newbie

    Joined:
    Aug 21, 2008
    #2
    I'll heartily second that request. I'd really really like to disable the irritating warnings. If I liked them I'd use a Microsoft product.

    Even so, if Apple is going to enable a tiresome annoyance, the least it can do is let users turn the bloody alerts off. I for one have hands often on the edge of repetitive strain problems. The last thing I need is to be forced to continually click OK boxes unnecessary to begin with. Grrr.
     
  3. nightfly13 thread starter macrumors 6502a

    nightfly13

    Joined:
    Jul 17, 2008
    Location:
    Ranchi, India
    #3
    After searching Mac Rumors and posting, I posted this thread subject's question into google and tried the top 2-3 options. One says look for an action script and remove it (wasn't there anymore in Snow Leopard) and another has me apply a line of javascript into the downloads folder (made no difference) so I'm still stuck.

    Insight would be great!
     
  4. omni-impotent macrumors newbie

    Joined:
    Feb 20, 2008
    #4
    I totally agree with you! I have same problems with .nzb files. One time I thought I had started downloading a very large news file and then went out for dinner with my girlfriend. I suggested coming back to mine afterwards to read some news together for a few hours but then I realised the download was stuck at the warning dialog. Needless to say, she was not impressed. :p

    Anyway, I have read of disabling this feature completely but could be dangerous. I think the most elegant solution is to setup a script scanning the download folder for .nzb files and removing the warning for just those files.

    I will see if I can find anything or write my own script. If you hear something, can you let me know? :) Cheers
     
  5. nightfly13 thread starter macrumors 6502a

    nightfly13

    Joined:
    Jul 17, 2008
    Location:
    Ranchi, India
    #5
    Sorry to hear about how this issue had a negative impact on your love life :)

    Reading news together can be very bonding :)

    So yeah, I think I've tried both of the methods you mentioned - they're for older versions of Safari/Leopard. At least they didn't make any difference for me.

    I'll keep spamming here in case someone has a solution..
     
  6. Jamesthatcher macrumors member

    Joined:
    Jun 21, 2009
    #6
    **** man disaster
     
  7. omni-impotent macrumors newbie

    Joined:
    Feb 20, 2008
    #7
    Ok. After reading through many pages, the best solution (at least for me) is to setup an automator folder action. The key is to use the still functioning terminal command "xattr -d com.apple.quarantine <filename>" to disable this annoying download warning message.

    An example can be found here: http://henrik.nyh.se/2007/10/lift-the-leopard-download-quarantine but I found it didn't work so well on 10.6. All I did was make an automator folder action attached to my ~/Downloads folder with the terminal command:

    Code:
    find ~/Downloads -name *.nzb -exec xattr -d com.apple.quarantine {} \;
    This finds all files with the extension .nzb and removes the quarantine tag. Hope that helps. :)
     
  8. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #8
    MacPilot has an option to turn off the "Downloaded from some website" dialogue. I'm not sure if this works for the OP.. I have tried using the hidden option within Leopard and that worked fine but I haven't tried it yet on Snow Leopard. MacPilot is shareware though. But I think it has a 14 day trial.
     
  9. nightfly13 thread starter macrumors 6502a

    nightfly13

    Joined:
    Jul 17, 2008
    Location:
    Ranchi, India
    #9
    Hmm is the automator action something that has to be done just once or something you have to do regularly. Often I want to start the NZB I just DL'd immediately - and that's where the extra click is annoying.

    Funny to think how much energy we've spent talking about fixing this - that would have been like a years worth of clicking the dialog box. :)
     
  10. omni-impotent macrumors newbie

    Joined:
    Feb 20, 2008
    #10
    haha I have to admit, I have spent a few hours reading and thinking about it. However, a few hours now compared to a lifetime of clicking away the annoying prompt and possibly getting RSI from this due to my large multi-monitor setup. This is combined with the fact that apple quarantine stopped me from getting laid once and so I promised it will never do it again. Not on my watch. Not to anyone else either. Who's with me??!?? *ahem*

    Anyway, the above folder action automator is called automatically when a new file appears in the ~/Downloads directly. So once it is set up, it will do everything automatically without you having to manually run it.

    A minor question remains if this works for large .nzb files that take awhile to download as well. I will test this for Firefox and Snow Leopard tonight. If that is the case, I will add the waiting for file to finish downloading to the automator script and post it here.

    Thanks. :)
     
  11. dogen macrumors newbie

    Joined:
    Aug 21, 2008
    #11
    Can you be more specific about how to ditch the warning in MacPilot?
     
  12. dogen macrumors newbie

    Joined:
    Aug 21, 2008
    #12
    Apologies, forgot to quote the relevant post:

    How is this done?
     
  13. levytv macrumors newbie

    Joined:
    Aug 6, 2010
    #13
    well im sorry if this is two years late - but in macpilot on the left you scroll down to system and there is a dialogue to check to disable the annoying warning.
     

Share This Page