How to Disable Sleep Mode?

Discussion in 'macOS' started by schwine1, Apr 22, 2011.

  1. schwine1 macrumors regular

    Joined:
    Sep 13, 2008
    #1
    How is the Sleep Mode disabled in the Mac Pro Tower?

    Thanks.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Why do you want to disable it? Why can't you turn it off ( :apple: > Shut Down)?
     
  3. schwine1 thread starter macrumors regular

    Joined:
    Sep 13, 2008
    #3
    I have an anti-virus program running for several hours and the only way to keep it going is to disable the sleep mode. I also have Windows 7 through VMware, and the virus program checks this OS in particular for virus problems.

    I have been able to disable the Mac screen saver but not the Mac sleep mode.
    I'm not sure if this can be done, and as a result, the virus program stops working when the computer is in sleep mode.
     
  4. schwine1 thread starter macrumors regular

    Joined:
    Sep 13, 2008
    #4
    I've found it now.
    It's under Energy Saver in System Preferences.
     
  5. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #5
    Ah, I misunderstood.
    Btw:
    There are currently no viruses for Mac OS X in public circulation, only a handful of trojans and other malware, which have to be installed manually via entering the administrator password.
    The only anti-virus you need to protect your Mac is education and common sense.

    Mac Virus/Malware Info
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    You can use Caffeine to temporarily override your Energy Saver settings, with a single mouse click. And as has already been stated, you don't need anti-virus software to protect your Mac from malware. Read the Virus/Malware link that simsaladimbamba posted.
     
  7. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #7
    Go to "System Preferences -> Energy Saver" and slide the computer sleep slider to "Never". The system should now never go to sleep unless you tell it to.
     

Share This Page