How to disable sleep via IR remote?

Discussion in 'iMac' started by ViperrepiV, Feb 12, 2009.

  1. ViperrepiV macrumors regular

    Joined:
    Jan 25, 2008
    #1
    I have a Logitech Harmony universal remote, and it supports control of the iMac. The only problem is that when i switch "activities" on the remote, to "watch tv" for example, the remote shuts off anything that isn't used in that activity. So what it does for the iMac, is it puts it to sleep (via the IR port).

    Previously, I didn't even know this was possible, but it is. A icon comes up on my iMac that is a picture of the remote with some zZZzzz over it.

    Is there any way to disable sleep via remote on the iMac? It is kind of driving me nuts because when my gf wants to watch TV, it sleeps the computer, even if i am working on it!!
     
  2. Arne macrumors regular

    Joined:
    May 14, 2006
    Location:
    Germany
    #2
    you can either disable the IR-Port completely or you can pair you mac remote with your iMac, so your iMac won't react to any other remotes.
    You can find the settings in System-Prefs->Security
     
  3. nusynergy macrumors regular

    Joined:
    Jul 3, 2008
    Location:
    Kent - UK
    #3
    Dont think he wants to stop using the Harmony.

    Its a software issue with the remote.. Look about on the net to see if you can download an update for the imac settings on the remote. A friend of mine had a similer issue and that fixed it.
     
  4. Felder71 macrumors member

    Joined:
    Aug 26, 2008
    #4
    I believe you can have a setting for the device itself that says you want to leave it on all the time. Then it won't put it to sleep. Of course, it won't wake it up either since it assumes the iMac is ready and waiting.
     
  5. ViperrepiV thread starter macrumors regular

    Joined:
    Jan 25, 2008
    #5
    Thanks, I'll see if I can find this setting tonight!
     
  6. risn3rdday macrumors newbie

    Joined:
    Apr 26, 2009
    #6
    Any fix for this?

    I have fixed the issue I was having. If you go into the Harmony software and go to Devices. Then select your Mac. Choose the option for power management and tell it you want to leave your mac on all the time. It will ask you if you have one button to turn it on and off or separate buttons. There is just one. Which one? PLAY. So select that as your power button and update your remote.

    This fixed another issue I had when iTunes started to play whenever I switched to my Mac Mini HTPC. Since the remote was sending the Play command thinking it was turning on my mini. Now it doesn't send the command.

    I hope this helps you too!
     

Share This Page