How to Disable Transparency Effects in macOS Mojave

Discussion in 'Mac Blog Discussion' started by MacRumors, Dec 14, 2018.

  1. MacRumors macrumors bot

    MacRumors

    Joined:
    Apr 12, 2001
    #1
    [​IMG]


    In macOS, transparency - or more properly, translucency - is a visual effect many apps use to create a sense of depth by hinting at content residing in the background.

    [​IMG]

    An example of transparency is when content behind a window shows through in interface elements like menus and sidebars. It's evident in the screenshot above, for example, in which the colors of the desktop wallpaper bleed through the sidebar in the Photos app.

    A similar effect is sometimes used within app interface elements that are windowed, allowing window content to show through other elements like toolbars. An instance of this can be seen below, where the folders are visible through Finder's toolbar as if through frosted glass.

    [​IMG]
    Transparency enabled (left); transparency disabled

    The effect can look cool, but it can also be distracting if you're trying to focus on content, especially if you're editing photos. Fortunately, macOS lets you turn off transparency, but the way to do it isn't immediately obvious. The following steps show you how.

    How to Disable Transparency in macOS Mojave
    1. Launch System Preferences from your Mac's Dock, from the Applications folder, or from the Apple menu bar (? -> System Preferences...).
      [​IMG]

      Select the Accessibility preference pane.
    2. In the sidebar, under Vision, click Display.
      [​IMG]

      Check the box next to Reduce transparency.

    Article Link: How to Disable Transparency Effects in macOS Mojave
     
  2. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #2
    Does this save resources at all? I used to do this on my iphones back in the day thinking I saved CPU cycles and ram.
     
  3. martyjmclean macrumors regular

    martyjmclean

    Joined:
    Jan 24, 2018
    Location:
    Sydney, NSW, Australia
    #3
    Setting your Accent Colour to Greyscale also turns off wallpaper window tinting. Another tip to increase legibility.
    --- Post Merged, Dec 14, 2018 ---
    None of this makes any difference on modern computers.
     
  4. Bugsi macrumors newbie

    Joined:
    Dec 14, 2018
    #4
    So. . .exactly the same way you disable it for the last several MacOS operating systems?
     
  5. edrozenberg macrumors newbie

    Joined:
    Sep 29, 2015
    #5
    Recent betas remove the window tinting when using any accent color with reduce transparency enabled (I'm on 10.14.3 Beta (18D21c)). This is great. Tinting still remains in the dock, notification center, and alerts - no big deal, window tinting was the one that was really annoying.
     
  6. autrefois macrumors 65816

    autrefois

    Joined:
    Oct 22, 2003
    Location:
    Somewhere in the USA
    #6
    Can you please define “modern” computers? Do you mean anything that supports Mojave — for example, would a MacBook Pro or Air from Mid-2012 be considered modern?
     
  7. n-evo macrumors 65816

    n-evo

    Joined:
    Aug 9, 2013
    Location:
    Amsterdam
    #7
    There's no accent color called "Greyscale". It's called "Graphite".

    These fancy effects are handled by your Mac's GPU so disabling them won't save your CPU.
     
  8. mac1984user macrumors 6502a

    mac1984user

    Joined:
    Dec 10, 2009
    Location:
    United Kingdom
    #8
    I still do this on my iPhone XR (started with the iPhone 5 and iOS 7). It’s less about resources at this stage, and more that I’ve come to prefer low transparency and reduced motion.
     
  9. opeter macrumors 65816

    opeter

    Joined:
    Aug 5, 2007
    Location:
    Slovenia, EU
    #9
    @mac1984user:
    If I remember correctly, with TinkerTool you can disable most of the animations.

    Or if you know the commands for Terminal. ;)
     
  10. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #10
    Same here! I thought I was the only one that did this. I am so happy to have found Reduced Motion for my MacBook thanks to this article, all these years I had no clue it existed (same for transparency for Mac OS). I've used both since my 6+ iPhone and prefer it.
     
  11. fairuz macrumors 68000

    fairuz

    Joined:
    Aug 27, 2017
    Location:
    Silicon Valley
    #11
    These effects might be GPU-intensive, which matters if you don't have a dGPU. IDK about transparency, but I've seen other effects lag on weaker Macs.

    Anyway, I'm glad they have this option (along with high contrast mode) because it makes things easier to see for me. I don't have a disability, but when I'm using a computer all day at work, this stuff matters.
     
  12. killr_b macrumors 6502a

    killr_b

    Joined:
    Oct 21, 2005
    Location:
    Suckerfornia
    #12
    The transparency works backwards of how it should. The active window should be opaque, and the ones not in use should be semi transparent to fade into the background. I don’t understand the point of the way it is right now.
     
  13. puma1552 macrumors 603

    Joined:
    Nov 20, 2008
    #13
    What I don't like about it is how when reduce transparency is on, for some reason all of your function control popup windows like brightness, volume, etc., are basically gray now instead of bright white...seems opposite of how it should be.
     
  14. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #14
    Really wish I could get rid of this dropdown menu transparency, it's almost a deal breaker for me.

    Screen Shot 2018-12-16 at 9.17.41 PM.png
     
  15. n-evo, Dec 17, 2018
    Last edited: Dec 17, 2018

    n-evo macrumors 65816

    n-evo

    Joined:
    Aug 9, 2013
    Location:
    Amsterdam
    #15
    I hope you realize that's an issue with whatever third-party browser and/or theme you're using and not an actual macOS bug.
     
  16. martyjmclean macrumors regular

    martyjmclean

    Joined:
    Jan 24, 2018
    Location:
    Sydney, NSW, Australia
    #16
    You still knew which colour I was talking about.
    I hope you realise they were being sarcastic.

    Stop being obtusely fastidious.
     
  17. MacGizmo macrumors 65816

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #17
    LOL! Dontcha just hate when people do that?!!!
     
  18. n-evo, Dec 17, 2018
    Last edited: Dec 17, 2018

    n-evo macrumors 65816

    n-evo

    Joined:
    Aug 9, 2013
    Location:
    Amsterdam
    #18
    Yeah, I did. However your instructions are meant for someone with less knowledge than me. "Greyscale" and "Graphite" are simply two wildly different things in the macOS landscape. If someone actually starts looking for "Greyscale" chances are they'll end up in Accessibility turning their entire screen black and white. Try to accept a well-meant correction with a little bit more grace. Especially when a fairly small textual difference makes a world of difference in practice.

    Hah, I actually didn't catch it so I'll give you that. Truth be told it wouldn't be the first time around here someone doesn't know where the bug is actually coming from and thinks it's a macOS bug.
     
  19. stevenjwallach macrumors newbie

    Joined:
    May 16, 2011
    #19
    perhaps someone can help with this situation. after upgrading to mojave, the fonts displayed in the "save as" window, for all apps is greyed out. i tried using the "show options" to correct this, but no luck. the fonts for the files and directories using FINDER work and are clear. only the files displayed when using the "save as" command (also export file). any suggestions? i tried transparency setting, but that did not help. running on mac laptop. same problem on my mac mini server.
     
  20. StellarVixen macrumors 65816

    StellarVixen

    Joined:
    Mar 1, 2018
    Location:
    Earth
    #20
    There is also tinting in Safari address bar drop down list. Tinting shall be gone from everything when "Reduce Transparency" is turned on.
     

Share This Page