How to disable User folder and Macintosh HD shares?

Discussion in 'Mac OS X Lion (10.7)' started by fishbaitfood, Jan 14, 2012.

  1. fishbaitfood macrumors newbie

    Joined:
    Jan 14, 2012
    #1
    Hi there,

    I recently received my new iMac, and ofcourse wanted to share a public folder with my Windows 7 laptop, and vice versa.

    So, in OS X Lion, I checked File Sharing, and the folder "Public", under my User(my name) folder, was succesfully shared.
    However, through Windows 7, I could not only see the shared public folder, but also the iMac's full User(my name) folder and Macintosh HD folder, with all their contents.
    Obviously, I don't want any other PC to see these two main folders.

    I haven't found an option to disable this, or a solution via Google search, hence this thread.

    So, what's shared now (accessible via Windows pc):
    /Users/(my name)/Public
    /Users/(my name)
    Volume Macintosh HD


    Under the File sharing settings, it only shows the folder "Public map of (my name)", with the correct restrictions.

    Why does OS X Lion automatically share everything?
     
  2. mainstay macrumors 6502

    mainstay

    Joined:
    Feb 14, 2011
    Location:
    BC
    #2
    are you authenticating with the same username/password on both machines?
     
  3. fishbaitfood thread starter macrumors newbie

    Joined:
    Jan 14, 2012
    #3
    No, both computers are signing in to each other as a guest.
    I don't have to give a password on any computer in the network.

    If I open the Info window of my User(my name) folder, the shared checkbox is unchecked. Same with the Macintosh HD. Which is desired.
    But Windows PC can access those main folders anyway.
     
  4. mainstay macrumors 6502

    mainstay

    Joined:
    Feb 14, 2011
    Location:
    BC
  5. fishbaitfood thread starter macrumors newbie

    Joined:
    Jan 14, 2012
    #5
    I cannot explain myself better.
    I don't have problems with sharing, except that OS X Lion shares everything, instead of the only, manually, shared folder.
     
  6. mainstay, Jan 16, 2012
    Last edited: Jan 16, 2012

    mainstay macrumors 6502

    mainstay

    Joined:
    Feb 14, 2011
    Location:
    BC
    #6
    If you turn file sharing off, do you still see the folders?

    How are you connecting (just through Windows Explorer?)?

    Do you actually have the ability to browse inside these folders and create / delete files?

    If you command-I a folder / file, what permissions do you see?

    I can only think that you have the same username and password on both systems... but you say you don't have any passwords at all... which is boggling to me.

    ....


    also, in File Sharing ... what folders do you see as being shared? and then in Options, what users do you see as having access privileges?
     
  7. fishbaitfood thread starter macrumors newbie

    Joined:
    Jan 14, 2012
    #7
    Now that you've mentioned it, I DO use the same username and password on both my laptop and my iMac. And yes, when tested, I can only see those two big folders when on my laptop, not on any other person's computer in the network.
    That's why those big folders aren't checked as "shared".
    So it's kinda okay now. :)

    Thank you!
     

Share This Page