How to do a quick restart?

Discussion in 'macOS' started by msmth928, Jan 6, 2010.

  1. msmth928 macrumors regular

    Joined:
    Jun 3, 2009
    #1
    Is there a way to quickly restart system processes on a Mac without having to sleep and then wake the system?

    Why do I have to do this? Because the stupid sound controls stop working after long periods of sleep (usually overnight) and the only way to get them back is to sleep and then quickly wake the system. But it's a pain because you have to re-enter your password each time.

    Hope someone can help - Apple are fully aware of the problem as there's lots of threads and posts about it on Apple's and other forums.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    No, because what your asking is done through the sleep. Just change the security so you're not being prompted for your password. That's what I do. Its in sleep mode whenever I'm not using it. I wake it up and I'm off like a herd of turtles - no need to re-enter my password.
     
  3. msmth928 thread starter macrumors regular

    Joined:
    Jun 3, 2009
    #3
    There must be some process that gets confused or turns off - is there no way to restart them all? Think in windows you just need to restart explorer..
     
  4. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #4
    On OS X, the equivalent of restarting explorer is to do a Force Quit then pick Finder and select Relaunch. I decide to do this from time to time when all my desktop icons disappear for some reason. My machine only reboots for system updates so I don't consider the occasional need to relaunch finder a big deal at all.
     
  5. msmth928 thread starter macrumors regular

    Joined:
    Jun 3, 2009
    #5
    I tried that earlier but it didn't fix my volume controls :(
     
  6. nufanec macrumors regular

    Joined:
    Sep 10, 2005
    #6
    If you're running Snow Leopard then you could set that it only requires the password after 1 minute of sleep. This is in the Security system preference.

    Also, never heard of this "issue". Have you tried an archive and install of your software?
     
  7. msmth928 thread starter macrumors regular

    Joined:
    Jun 3, 2009
    #7
    Yep - it happened on a clean Leopard install, an upgrade to Snow Leopard install and a clean SL install too :(

    The problem is quite common, it's been posted about lots - especially on their own support forums.
     

Share This Page