how to download apps??

Discussion in 'Mac Apps and Mac App Store' started by daniel55645, Mar 5, 2011.

  1. daniel55645 macrumors newbie

    Joined:
    Mar 5, 2011
    #1
    I go to the app store on the iMac and select buy. it asks for my password. after i put it in nothing happens. Am I doing something wrong or is it messed up?
     
  2. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #2
    What App are you trying to buy?
    That might help us isolate the problem
     
  3. MeganMac macrumors newbie

    Joined:
    Mar 5, 2011
    #3
    App store

    I'm having exactly the same problem. I'm on the App store trying to download the MindNode free app. I enter my AppleID information but then nothing happens. I thought it might have been the app itself, but my brother who also has a MacBook Pro downloaded it with no problem. I had just installed some new software shortly before trying to download some apps, however I don't know if that's the cause of the problem as I haven't tried to download an App before now. Could anyone help?
     
  4. daniel55645 thread starter macrumors newbie

    Joined:
    Mar 5, 2011
    #4
    I'm trying to download the virtualDJHome but ive tried others too and nothing happens
     

Share This Page