How to enable handoff for the first time

Discussion in 'OS X Yosemite (10.10)' started by iBlazed, Jul 7, 2014.

  1. iBlazed macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #1
    Are you supposed to actually pair your Mac to your iPhone with bluetooth first? I'm trying to do it and my 2013 MBA refused to connect to my iPhone 5. Have no idea how to get this feature running.
     
  2. TheColtr macrumors regular

    Joined:
    Feb 1, 2014
    Location:
    California
    #2
    Here's how it works. No one really knows for sure but this is how I got it to work. On your Mac with DP 3 go to settings > general > enable handoff. On the iPhone/iPad side running iOS 8 beta 3. Settings > general > enable handoff. Then try restarting both devices. On the mac you should see your device in the Bluetooth pannel of the settings app. If this doesn't work try logging out of iCloud on both devices, restart both devices, Log into iCloud on iOS device then log into iCloud on the mac.
     
  3. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #3
    I see the iPhone in the bluetooth panel, but are you actually supposed to pair the devices? Because when I try to I always get an error of some sort.
     
  4. Afbar1114 macrumors 6502a

    Joined:
    Jun 18, 2012
  5. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #5
    Your Mac may not be compatible then.
     
  6. jpadhiyar macrumors regular

    Joined:
    Oct 15, 2012
    Location:
    Ahmedabad, India
    #6
    Click on Apple icon from top left corner. Then go to System Preferences -> General. And then enable "Allow Handoff between this Mac and your iCloud devices"

    Make sure your Mac and iPhone are on same network and using same iCloud id on both devices.
     
  7. K4LK macrumors 6502

    K4LK

    Joined:
    Jun 18, 2009
    #7
    In Settings > General,

    my mid-2011 MBA has the setting for Theme (light/dark) but no choice to enable handoff. It was upgraded to Yosemite starting with DP1.

    my early-2011 MBP has NO setting for Theme but I can enable Handoff. It was upgraded to Yosemite yesterday with DP1. Of course there are updates in the MAS. Will see if DP3 removed these.
     
  8. busch macrumors newbie

    Joined:
    Jun 18, 2014
    Location:
    Stuttgart, Germany
    #8
    This setting is also gone on my Macbook Air 2011 on DP3, while the device should be compatible according to this graphic:

    [​IMG]
     
  9. K4LK macrumors 6502

    K4LK

    Joined:
    Jun 18, 2009
    #9
    After updating the MBP to DP1, settings > general match the MBA. I ordered the mid-2012 WiFi/bluetooth card. We'll see if that works.
     
  10. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #10
    Unfortunately none of this answers my question if you're supposed to actually go through the process of linking your Mac and iPhone via Bluetooth before enabling handoff
     
  11. TheColtr macrumors regular

    Joined:
    Feb 1, 2014
    Location:
    California
    #11
    No, iCloud links that by itself. If you see their devices in the Bluetooth pannel of your mac then your good. You can even test if they are linked with icloud because if you try to delete the device from Bluetooth it will say "this device can't be removed. Please sign out of icloudto remove this device" or something like that. So if you see your device in bluetooth settings pannel automatically you're good.
     
  12. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
  13. RobQuads macrumors regular

    Joined:
    Jul 11, 2010
    #13
    yup the option is also gone from my MBA2011

    So can we confirm the option is still available on other machines on DP3 (macrumers reported the option in the general settings as being removed but added on the ios side)
     
  14. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #14
    And oddly even though my handoff isn't working, airdrop is working great. Can't figure out what the issue might be. Also, I'm not getting calls and texts on my Mac.
     
  15. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #15
    I haven't paired anything. I just enable handoff on my 5s and enable handoff on my iMac and that is all I did and it works.

    Both of my devices are also on the same iCloud account and signed in with both on the same WiFi network. If this matters, I'm not sure but that is my current setup.

    I am receiving phone calls, I can make phone calls and also receiving texts on my Mac from the green bubble people.

    Prior to DP3 I was getting green texts on my Mac but phone calling didn't work and handoff was not very consistent. With iOSb3 and 10.10DP3 things are much much better.
     
  16. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #16
    Wish I could say the same. I have the same setup, logged in on the same iCloud account on both devices. No dice, they refuse to communicate. Very unfortunate.
     
  17. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #17
    After tons of wrestling the OS's and signing in and out of iCloud a few times, it finally started working! So happy! What an amazing feature. Maybe it also has something to do with the fact that Back to my Mac was unchecked, it started working after I checked it in.
     
  18. GreyOS macrumors 68030

    GreyOS

    Joined:
    Apr 12, 2012
    #18
    no one i know ever got it working on MBA 2011 in previews 1 and 2 anyway. looks like it won't be available for mba 2011 at this rate :(
     
  19. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #19
    Now handoff is working but I still can't take or make phone calls. It worked once but that was it.
     
  20. rhwd2003 macrumors newbie

    Joined:
    Oct 8, 2011
    #20
    I am having the same issue, I get my phone calls on my mac but cant get them to show up on my ipad all on ios 8/yosemite. Hand off doesnt show up either. I cant sign out of icloud on yosemite due to parental controls is what it says.
     
  21. gopherhockey macrumors regular

    gopherhockey

    Joined:
    Apr 2, 2010
    #21
    I had to reboot both devices for things to work.

    No pairing of bluetooth necessary.
     
  22. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #22
    They're only supposed to show up on your Mac. You're not supposed to be able to take phone calls on your iPad.
     
  23. Fenderf4i macrumors member

    Joined:
    Aug 19, 2013
    #23
    Yes you are.
     
  24. langscinema macrumors member

    Joined:
    Jun 5, 2014
    #24
    I've had similar experience as the original post here
    Running 5s and 2011 mid MBA.....have never been able to get handoff to work on DP1-DP3
    I was able to get SMS working on each DP versions
    I now can also use calls to and from the MBA....each call placed or received activates FaceTime which i can see listed above next to the apple logo so I'm guessing calling feature uses the wifi link
    Each time i try to connect via bluetooth it tells me "network unavailable" so I'm guessing this is the issue which is preventing the handoff feature from working
    From what I can gather, I would sum it up as thinking:
    WiFi = sms / phone calls (continuity) features
    Bluetooth = handoff features
     
  25. iBlazed thread starter macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #25
    My mistake, I guess you are. That's pretty cool!
     

Share This Page