How to enable Hey Siri activation on a mac with Sierra

Discussion in 'macOS Sierra (10.12)' started by tywebb13, Jul 15, 2016.

  1. tywebb13, Jul 15, 2016
    Last edited: Jul 16, 2016

    tywebb13 macrumors 68000

    Joined:
    Apr 21, 2012
    #1
    So far apple have not enabled voice command Hey Siri activation for a mac with Sierra - which is disappointing since if we have Siri, why not? There should be nothing stopping it. Apple might not have done it because they think it might interfere with nearby iPhones. Well I don’t have an iPhone so I don’t care about that. I have an android phone so it is not going to affect me (or as MLVC points out below, even if you do have an iPhone and don't want such interference you can change it to something else instead like "Hello Siri" - it just has to be at least two words).

    Currently by default you have to click the icon to activate Siri. Let's say I don't want to click the icon to activate it. Let's say I want to activate it just by saying "Hey Siri" instead. Then you can turn on this feature as follows:

    1. Go to apple menu -> System Preferences -> Accessibility -> Dictation

    If options are greyed out you may have to enable Enhanced Dictation in Dictation Preferences and wait for it to download and install. This is actually in the Keyboard Preferences so when this is finished, go back to Dictation in Accessibilty.

    2. Tick Enable the dictation keyword phrase and change it to Hey

    3. Click Dictation Commands

    4. Tick Enable advanced commands

    5. Press + to add a new command

    6. Fill in settings as follows:

    For When I say - type Siri

    For While Using - leave it as Any Application

    For Perform - select Open Finder Items - navigate to Applications folder and select the Siri App - click Open

    7. Click Done

    ————————

    Note this is a bit buggy because it might not work at first and you may have to go back and untick “Hey” and “Siri” - go out of system preferences - and then back in again to retick them. It should work after that.

    Also, to close Siri with a voice command, just say goodbye.
     
  2. karsten macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #2
    hey thats brilliant man. any tips on the buggy part? I got everything entered in but dictation wont' trigger on hey siri.. thx
     
  3. tywebb13, Jul 16, 2016
    Last edited: Jul 16, 2016

    tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #3
    Yeah. The bug is that it seems to have trouble getting started. So you have to go back and untick "Hey" and "Siri", close system preferences. Then go back in and retick them.

    It works after that - at least for me. I did it on a 2011 mba a few hours ago.

    I'll try it on a 2014 mbp tomorrow and make a video of the process.
     
  4. karsten macrumors 6502a

    karsten

    Joined:
    Sep 3, 2010
    #4
    looks like i can get it to consistently trigger by getting like 1 inch from the microphone and talking loud. thats even with the mic gain all the way up
     
  5. tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #5
    I didn't have to be so close or be loud.

    I made a youtube video:



    I put instructions in the comments section for the video. Same as above.
    --- Post Merged, Jul 16, 2016 ---
    I'm having a bit of fun with this now.

    I made another youtube video asking Siri to talk to Cortana. The response is very funny.

     
  6. tywebb13, Jul 16, 2016
    Last edited: Jul 16, 2016

    tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #6
    I should point out too that these instructions are for the current beta. For future betas, the instructions may change. Apple may even simplify it with a single button.
     
  7. MLVC macrumors 6502

    Joined:
    Apr 30, 2015
    #7
    Works perfect for me, I just changed it to Hello Siri since my phone is usually next to my Mac.
     
  8. tywebb13, Jul 16, 2016
    Last edited: Jul 16, 2016

    tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #8
    I enabled it in my mbp now. But in so doing I recorded the process this time and therefore have been able to put my instructions into an instructional video:



    Note: I recorded this in 1080p and so it looks much better if you go full screen and select 1080p resolution.
     
  9. 12CoreMP macrumors member

    12CoreMP

    Joined:
    Dec 26, 2015
    Location:
    Edinburgh, Scotland
  10. tywebb13, Jul 19, 2016
    Last edited: Aug 6, 2016

    tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #10
    Unfortunately Apple still are still not providing a single Hey Siri button in DP3 to simplify the process of enabling it - which I reckon they could do.

    But the good news is that if you enabled it using my instructions in DP1 or DP2 then it still works after updating to DP3.
     
  11. tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #11
    Same for DP4. I think if they were going to make a Hey Siri button they would have done it by now. So maybe we are stuck having to do it via my instructions above.
     
  12. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #12
    definitely should not be 'hey siri'.... since my iphone is right on my desk, next to my mac (don't want both devices responding)...
     
  13. tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #13
    Well that's OK. You can change it to anything you want - so long as it is at least two words.
     
  14. WestCoastCommodore macrumors newbie

    WestCoastCommodore

    Joined:
    Jan 6, 2016
    #14
    In honor of Mr. Scott, I went with this phrase:

    [​IMG]
     
  15. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #15
    was just suggesting that if/when apple decides to implement this...
     
  16. 32828870 Suspended

    Joined:
    Jun 23, 2016
    Location:
    New York and Berlin
    #16
    Fantastic. It's working perfectly running the latest 10.12 developer beta. It did require unchecking and checking the options as you suggested and after a few minutes it kicked in. I'm running 10.12 on a nMac Pro6,1 with 3 27" Apple Displays. In "Sound" preferences, I selected the middle display of the 3 for "Input", kept the gain at 50%.

    Side note: Have a pair of Bang & Olufsen S3 Bluetooth speakers and there's no interference. Interesting as wifi and bluetooth issues have plagued OS X since Apple switched from separate Broadcom wireless and bluetooth cards to a single combined Broadcom card around late 2012-2013 with WiFi ac + BTLE 4.x. As a developer I've been working with Apple engineering on this issue since 10.8 as wifi and bluetooth sound work perfectly running Windows in Bootcamp with the same hardware. Apparently Apple finally admitted the kexts/drivers have not been updated properly in OS X, accounting for the well known wireless contectivity issues that have plagued many. So far, wireless is working well in 10.12 but bluetooth audio is a mess, intermittently kicking in and out when using Apple's Magic Keyboard and Trackpad 2 and especially when copying files via SMB or AFP to networked devices.
     
  17. fischersd macrumors 68040

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #17
    So, you guys should scrap the "Hey" and "Siri" and just call it "Jarvis" so your other iDevices aren't waking up... :)

    I don't quite understand the "single button for "hey Siri" idea?" If you have to hit a key, what's the point of "Hey Siri"?
    If you want to enable it, why not have that in preferences? (Why would you need to toggle it on/off easily?)

    Holding Cmd+space launches Siri today (beyond the other two icons) - until they give us a similar option to "Hey Siri" (and hopefully allow us to rename "her"), I think that's all we're going to get.
     
  18. tywebb13 thread starter macrumors 68000

    Joined:
    Apr 21, 2012
    #18
    I said before you can change it to anything you want, so long as it is at least 2 words.

    And I know there is a keyboard shortcut. That's not what I meant by the single button. What I meant was a simpler way in system preferences to enable it.

    Such a thing has not come yet after several betas - so I think we are stuck with doing it via instructions above.

    One thing they should work on though is fixing the bug requiring unticking and reticking to get it to work. That should not be necessary. But because of the bug that is what we have to do at the moment.
     
  19. Scary Spice macrumors regular

    Scary Spice

    Joined:
    Jul 31, 2015
    Location:
    British Columbia
    #19
    I think you should call it 'Cookie Jarvis'
     
  20. RumorzGuy macrumors 6502

    RumorzGuy

    Joined:
    Sep 17, 2008
    Location:
    Guam, Mariana Islands, U.S.A.
    #20
    Thank you for these instructions. Very useful. I tried some online instructions at macworld.com, but they did not work, because Siri's prefs apparently do not allow you to select a customized keyboard command . . . at least I was not able to with Sierra GM on an early 2009 iMac.

    However, your instructions here worked great! :)
     
  21. fischersd macrumors 68040

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #21
    Psst. Yes, Siri's preferences do allow it. :) But, agreed, these instructions work great as well. :)

    Screen Shot 2016-09-11 at 12.57.48 PM.png
     
  22. RumorzGuy macrumors 6502

    RumorzGuy

    Joined:
    Sep 17, 2008
    Location:
    Guam, Mariana Islands, U.S.A.
    #22
    Weird. I tried about three or four different key combinations, and they were not appearing in that field, even after I left Siri's prefs and came back in again.

    At any rate, Siri is so half-baked at this point on the Mac, that I am not going to use it anyway. In fact, I already disabled it to save on system resources.
     
  23. Aneef macrumors regular

    Aneef

    Joined:
    Jun 4, 2015
    Location:
    Lahore, Pakistan
    #23
    Hey guys,

    When I ask Siri about anything, it displays the required text, but doesn't speak like she does on iPhones. How to activate her vocal cords?
    --- Post Merged, Sep 21, 2016 ---
    Nevermind, my bad. Had a problem with Boom 2 app. Siri speaks now.
     
  24. rcappo macrumors regular

    Joined:
    Apr 14, 2010
    #24
    I plan on using this to get Siri to work from voice commands when I update. I'll use "com" and "puter" as my two words.
     

Share This Page