How to enable new "sending from external email address" feature for Mail?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Edward To, Jun 27, 2010.

  1. Edward To macrumors newbie

    Joined:
    Jun 27, 2010
    #1
    I just bought my MacBook Pro with MobileMe several days ago, and am glad to see that the new "sending from external email address" feature has recently been implemented.

    I currently use a Google Apps email (essentially Gmail, but with my own custom domain), but have forwarded all email to my new @me.com address so that I can most seamlessly access the features of MobileMe in one location.

    However, I would like to send emails from within my MobileMe account as if it were my Google Apps mail. My custom domain email address is essential for my business.

    To do so, I set up the "sending from external email address" feature from within me.com. Now, whenever I send emails from my webmail at me.com, it shows as being sent from my Google Apps email rather than @me.com. Perfect.

    However, how can I do the same for the Mail.app on my Mac? Whenever I send mail from my MobileMe account from Mail.app, it still shows as being sent from my @me.com email address. Is the "sending from external email address" feature restricted to being used online at me.com's webmail?

    Thanks in advance,
    Edward
     
  2. rtkane macrumors regular

    rtkane

    Joined:
    Apr 29, 2010
    #2
    That only controls the webmail me.com email, but you can still do what you want:

    1. Go into Mail Preferences under Accounts.
    2. Click the + to add an account
    3. Enter your MobileMe account info. This will then verify and setup your MobileMe account
    4. Go back into Mail Pref/Accounts and select the account you just set up
    5. Change the Email Address entry to whatever email address you'd like the email to appear from.
    6. Click the outgoing server and edit the SMTP list
    7. Enter the account info for your server that handles your outbound mail for your Google Apps.
    8. Click advanced and enter your user/pass for the same
    9. Click Ok and you'll be back on the Accounts Preference, make sure you select the SMTP server you just entered and check "use only this server"

    Close out of the preferences and I *think* that'll get you set up the way you want. Try sending some test messages and since it's using the smtp server of your google account it should show to recipients the way you want it to.
     
  3. Edward To thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #3
    Thank you for the response.

    I just did what you said, and everything now works great! I can't understand why Apple didn't provide any official documentation for setting this up.

    A quick question: Why is step 5 required? (Change the Email Address entry to whatever email address you'd like the email to appear from.) Isn't it redundant since I am sending my emails via my Google Apps outbound SMTP anyway?

    Also, is it possible to sync all changes I make to my email in MobileMe back to my Google Apps email?

    Thanks,
    Edward
     
  4. rtkane macrumors regular

    rtkane

    Joined:
    Apr 29, 2010
    #4
    I believe step 5 controls the "reply to" value when sending email. If you didn't change it, when someone would reply to your message, it'd just go back to your address@me.com account vs. through your domain.

    I'm not sure about syncing back to google apps, however, if you're running all through MobileMe, would you be able to use that for all of your email needs and just have your Google account forwarding and then deleting or archiving so your google account doesn't fill up with old emails? Not sure of your needs, of course.

    EDIT: It may be redundant with Google since if I recall the paid google app will automatically change the outbound email if you have the preferences set right without it adding a "sent on behalf of" notation in outlook. Not 100% sure though, but I know I needed to set this up this way for my comcast account to work properly.
     
  5. Edward To thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #5
    The reason I ask about syncing MobileMe back to Google Apps is because I'm still quite iffy about using MobileMe. I am only using it because of how seamless it makes syncing to everything Apple with a "MobileMe" account (as opposed to setting up an additional Google Apps account specifically for email. I like the idea of having everything all-in-one).

    I would like to think of my Google Apps mail now as my "fail-safe" account. I would like to have it so that I can sync all the things I do via MobileMe mail to my Google Apps mail, so that if I ever decide to stop using MobileMe for any reason, I can simply stop forwarding my emails and return to using Google Apps.

    As it is now, my MobileMe and Google Apps accounts are two separate things. Nothing I read in MobileMe is marked as read in Google Apps. This would make switching back difficult as I would have to manually reorganize and transfer all my emails.

    Is this possible?
     
  6. rtkane macrumors regular

    rtkane

    Joined:
    Apr 29, 2010
    #6
    That I don't think is possible, unfortunately. But I'm not 100% sure. I totally understand where you're coming from as I'm just testing MobileMe out too to see if it's a viable long-term option. Good luck!
     
  7. Edward To thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #7
    Glad to see we have the same mindset; please let me know if you make any progress!
     
  8. Edward To thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #8
    Ok, I'm back again. Now I'm wondering how to properly set up "sending from external email address" on my iPod touch.

    I've tried to apply everything you told me to do previously with setting up my Mac Mail, onto my iPod touch. However, I cannot seem to apply Step 5: "Change the Email Address entry to whatever email address you'd like the email to appear from".

    The field for that under 'Settings > Mail, Contacts, Calendars > MobileMe > Account Info' shows my MobileMe address. It is greyed out and unable to be edited. I have tried to enter my Gmail address there to begin with during account creation, but it automatically resets back to my MobileMe address afterwards. I cannot find anywhere else to enter my desired Gmail address. Is it not possible to do so?

    I was also required to manually redirect the default outgoing server from smtp.me.com to smtp.gmail.com again, even though I had already done so within my Mac's Mail preferences. Is this normal? Shouldn't my MobileMe account remember my preferences for outgoing server settings, since I have set it to forward absolutely everything (including preferences) to my MobileMe cloud?

    Many thanks,
    Edward
     
  9. rtkane macrumors regular

    rtkane

    Joined:
    Apr 29, 2010
    #9

    I posted this in another thread... see if it works for you:

    1. Click Add Account in Mail settings
    2. Click Other, then Add Mail Account
    3. On the New Account page, enter your mobileme account info. It will then look up your account and put you into an IMAP settings page.
    4. Under address, enter the email address that you want people to see (myusername@personaldomain.com).
    5. For incoming mail, enter email.me.com and your mobileme user/password
    6. Under outgoing mail, enter your personaldomain.com smtp server as well as whatever username and password you use for that. Click Next. It will verify your account information and on the next page will show IMAP at the top and give you options to choose Mail and Note syncing.
    7. Click Save. It will configure the sync.
    8. Back under the settings/Mail, contacts, calendar area, click the account you just set up and go into the account info tab. Click the outgoing mail server and on the next page make sure only the server your using for your domain is showing (this may be an optional step, not sure)

    This is based on iOS 4 so I don't know if some of it varies much for an iPod touch.

    You lose the push email, but for me it works just fine. From here:
    http://forums.macrumors.com/showpost.php?p=10358486&postcount=14
     
  10. Edward To thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #10
    Thanks for the response.

    I would not like to add an 'other' account to mail, as that is precisely what I wanted to avoid by migrating from Gmail to MobileMe--so that I can have the convenience of all my data in one neat place.

    If I choose to remain using my current MobileMe setup on my iPod touch (meaning that I cannot set a custom email address), what exactly is affected? I have tried sending email from my iPod touch with its current MobileMe setup (myname@me.com, outgoing server smtp.gmail.com), and when the emails reach their recipients, they all show my desired custom 'from' address (myname@mydomain.com). They do NOT show that they were sent from my MobileMe mail (myname@me.com).

    The only mention of my emails being sent from my MobileMe mail is when I check MobileMe's "Sent" folder. There, it shows myname@me.com for each of the "From" fields in my emails.

    I stress, however, that when my emails reach my recipient they are displayed as being from myname@mydomain.com rather than myname@me.com.

    Why is there this discrepancy in "From" addresses depending on where I view my mail? Is the only downside of not being able to set a custom email address in MobileMe on my iPod touch that the emails in my "Sent" folder will show up as being from myname@me.com?

    Thanks,
    Edward

    EDIT: On a sidenote, I have found that with this entire "sending from external email address" feature, I am now unable to send and receive emails to and from myself (for quick reminders and such). When I send an email from MobileMe (using outgoing server smtp.gmail.com) to myname@mydomain.com, the message reaches my old myname@mydomain.com inbox, but does not get forwarded to myname@me.com (which is where I check all my emails now). Is this normal?
     
  11. rtkane macrumors regular

    rtkane

    Joined:
    Apr 29, 2010
    #11
    Doing some research, I believe when using the paid Google apps, the emails are able to be passed through Google's SMTP server as an alternate address (without Google-identifying header information that would cause the "on behalf of" message) if you've set it up that way on Google. This would let you take advantage of the push messaging on mobileme (whereas I can't do that with Comcast) and avoid having to use the "other" selection for adding email on the ipod. Google will actually replace the yourname@me.com with yourname@mydomain.com so it should work seamlessly for you--you shouldn't need an "other" account for your situation (whereas I have to use it for Comcast).

    As to your EDIT question, I'm not really sure--I don't have much experience with it and all of my answers to your questions are from research done in the past week trying to figure out how to do it on my end. Sorry!
     
  12. Edward To thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #12
    I appreciate you doing the research for me, thanks a lot! :p

    Would you mind just testing my EDIT question out for me, by emailing yourself through MobileMe and seeing if you receive the email in your MobileMe inbox? Or if the email gets stuck in the inbox of the address you are forwarding from?

    And have you managed to get your To-Do list to sync properly? I am having some difficulties... http://forums.macrumors.com/showthread.php?t=954881
     
  13. gpk macrumors newbie

    Joined:
    Jan 2, 2011
    #13
    Just to confirm that the steps presented by rtkane (28 June 2010) do work on my iPad. Outgoing messages carry no trace of MobileMe or the me.com domain, but do appear in MobileMe Sent items.

    You can also have MobileMe handle other things i.e. Calendar, Contacts. Make sure you turn off Mail (i.e. syncing) in the settings for your MobileMe account since rtkane's method already handles your email.

    At first it didn't work and I tried some of the steps at http://support.apple.com/kb/TS3234 still to no avail.

    In the end I deleted my MobileMe account and my "custom" MobileMe/custom SMTP account and started again, and it all worked.

    This reminded me of previous problems I'd had setting up Mail on a Mac... sometimes it takes a while for Mail to notice the changes in the settings...
     

Share This Page