[How-To] Enabling AHCI in 2011 Sandy Bridge iMac for Boot Camp

Discussion in 'iMac' started by Mashuri, Jun 27, 2011.

  1. Mashuri, Jun 27, 2011
    Last edited: Jun 27, 2011

    Mashuri macrumors member

    Joined:
    May 9, 2011
    #1
    I've been getting flooded with emails and PM's requesting how I enabled AHCI on my iMac, so I figured I should just post my reply here. I went ahead and used the same procedure that has worked for the 2011 MBP's. I found this post on OCZ's forums to be the most helpful:

    http://www.ocztechnologyforum.com/f...ing-AHCI-for-Windows-on-MBP-2011-now-possible

    So far everything has been working great, except it seems that my SSD's 4K reads / writes could be a little better than they are (the 4K QD32 reads / writes are fantastic though) but they are still way better than IDE mode. I did this about a week ago and, so far, Win 7 has worked great in Boot Camp and Parallels. Highly recommended for any Boot Camp SSD users! :cool:

    EDIT:

    FYI, I also had updated my drivers from MS to Intel. One person has mentioned that the Intel drivers on his MBP with Crucial M4 slows down after a while and that it speeds back up after a reboot. I haven't been able to confirm this on the iMac though.
     
  2. omvs macrumors 6502

    Joined:
    May 15, 2011
    #2
    The thread referenced says that messes us sleep in windows -- anyone know if that true on the iMac as well?

    I wouldn't mind the extra speed, but non-functional sleep would suck.
     
  3. skyrider macrumors newbie

    Joined:
    May 25, 2011
    #3
    Many thanks :D
     
  4. zepharus macrumors 6502a

    zepharus

    Joined:
    Aug 7, 2007
    #4
    Ok .. so I followed this to a T and it all seemed to work, the AHCI driver is installed and Im still only getting 6.8 for the disk performance in WEI. I also installed the RST driver from intel and it shows that NCQ is not operational on the drive.

    Im getting frustrated.. any help would be appreciated
     
  5. Mashuri thread starter macrumors member

    Joined:
    May 9, 2011
    #5
    Which SSD do you have?
     
  6. MacMany(H)ack, Jul 12, 2011
    Last edited: Jul 12, 2011

    MacMany(H)ack macrumors newbie

    Joined:
    Jul 12, 2011
    #6
    @: Zepharus

    NCQ will not work if the drive controller doesn't support it, as it speaks by itself, (Native-Command-Queueing) "natively".

    To every others "potentially" interested:

    in the OCZ forum it's reported that bootcamp control panel wil not work anymore if you switch to AHCI, this is definitively false, unless you use RST driver (current 10.1.0.1008) that's most likely you will never need it as it's for RAID "and" AHCI support, primarly RAID however...

    I'm playing with an W7 only install on my MBP8,3 that's running smoothly with AHCI ....BUT with the driver for the chipset that comes along with the latest release (currently 9.2.0.1030) of drivers for the 6 family to which belongs the HM65 chipset which is used into SB platforms.

    In the end, if you wish to run W7 bootcamped I can strongly recommend just to use the drivers installed by the latest "infinst_autol.exe" driver updater from Intel, and to DO NOT use RST which enables iastor.sys and use it for both legacy channels UNLESS you have replaced the optical unit with an HDD/SSD AND have the need to set up a physical RAID array.

    The only drawback is that even in this scenario in bootcamp control manager from within Windows you can't choose the starting drive, everything else works just fine, at least for me, and should be no problem if you could (most likely) choose the starting drive from OSX, not sure however, as already told...I'm temporary running a Windows-only system.

    Just remind that switching back from the RST suite of drivers to the flawlessy working ones isn't painless and could require a reinstall UNLESS you enjoy to mess up with the registry and everything else, the reason is that if you revert the main driver the next one you kick in wont recognize correctly the IDE channels leaving you with an half-good install, working however but not perfect as the first time you switch from IDE/ATAPI to AHCI, it probably could be of some use in that scenario to:

    -Uninstall completely RST better (for some extra caution) with the support of some program like Revo Uninstaller or the like of it.
    -Uninstall (sequentially) under device manager everything under IDE ATA/ATAPI, rebooting only at last, [better using the system variable devmgr_show_nonpresent_devices with value 1 under advanced system properties->system variables (add if missing)] and choosing to remove the device software as well if requested.
    -Reboot in MacOSX install disk and kick in the old backuped MBR.
    -Reboot in Windows and rereboot again twice, check everithing is back to normal with the old installed ide driver.
    -Follow again the procedure kickin in the patched MBR and switching to AHCI mode BUT, a big BUT, this time install only infinst_autol.exe and you're done with this, AHCI up and running with all of the benefits and the minimum of drawback.

    To do the right job it could be of some use a link to infinst_autol.exe enabling under compatibility tab the "run as administrator" checkbox and adding the expression "/OVERALL" at the end of the link pointer in this guise: \*\path_to_the_file\infinst_autol.exe /OVERALL , you must see this into the properties of the link, this means that the installer will overwrite every driver on your system with the latest even if a suitable and not too obsolete driver is already installed, you can check it's working because in the installer window you will see several driver being updated instead of just the one that's seems missing (AHCI).



    Hope it helps.

    Regards.

    P.S. gimme some feedback if this works even for you too, thanks...
     
  7. ArmanUV macrumors member

    Joined:
    Jul 15, 2010
    #7
    @OP, you mind putting up some before/after benchmarks? I'm thinking of doing this and I want to know if it's worth the downsides.
     

Share This Page