How to enter the AirPort Extreme password in Windows for a shared disk?

Discussion in 'Mac Accessories' started by osplo, Nov 18, 2009.

  1. osplo macrumors member

    Joined:
    Nov 1, 2008
    #1
    I just configured a shared USB disk in my Airport Extreme. My Mac can see it no problem, but when I try to access it from an XP machine it asks for a user/password.

    I have set the disk protection to "Airport Extreme password". As far as I know, there is only a password for it, but no user name or account related to it.

    Windows insists in asking for the user name, and I can't leave it blank. I tried putting the Airport Extreme name as the user name, but it doesn't work either.

    Does anyone knows how to do this?

    Thanks a lot.
     
  2. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #2
    I had to do a little registry hack for my Windows 7 PC so I could enter the password. I've got the details at home and I'll post up what I did when I get back from work.
     
  3. gumbyx84 macrumors 6502

    gumbyx84

    Joined:
    Dec 7, 2008
    #3
    You can also try connecting to the network share directly (//192.168.0.1/<share name>). I had to do it that way with my WinXP setups.
     
  4. osplo thread starter macrumors member

    Joined:
    Nov 1, 2008
    #4
    Registry hack for entering a simple password? You are scaring the hell out of me now. :)

    I was able to enter "guest" as the user and it took it, but obviously, it is connecting as a guest, not as the real thing (guests have different, usually more limited, access rights). Puzzles me...

    Olly, any help is welcome. Look forward for your post... Thanks!
     
  5. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #5
    I had to alter the LAN Manager Security settings to get mine working. I know this works in Vista and 7 Home Premium but don't know about XP.

    Run the registry editor (regedit.exe) and change the following key...

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\

    Change the key LmCompatibilityLevel from "3" to "1".


    Close the registry editor and save the changes then restart your computer

    Obviously, the usual warnings about backing up your Registry before making any changes apply. :)
     
  6. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #6
    OP - Pardon the obvious question, but have you installed AirPort Utility for Windows from Apple's support site? It includes a program called AirPort Base Station Agent, which mounts any disks attached to the base station automatically on startup and maps it as a network drive. It asks for your password once and stores it for you if you so choose.
     
  7. osplo thread starter macrumors member

    Joined:
    Nov 1, 2008
    #7
    No, I haven't, of course :)

    I didn't even know this was necessary. In fact, the brief manual does not say a thing about this on the disk sharing section. This is the part of Steve Jobs' minimalism that I don't like: if you need a manual that has more pages, please, don't trim these pages out!

    (Hey, I love Apple products anyway)...

    I'll try to install the Agent and see. Hope that this asks for a single password and not a user account too!

    Thanks a lot.
     
  8. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #8
    Anytime. There are other ways to mount the disk, but the solution I posted is definitely on of the easiest. It's been a while since I've set up disk sharing with my Time Capsule (works the same as AEBS I believe), and I have mine set up with disk password (so no accounts either), but I do believe that it doesn't ask for a username. If it does, you could try using the name of the disk rather than the AEBS as a username.

    Also, the manual for the AEBS actually mentions installing Bonjour for Windows to be able to access attached hard drives (page 19 on the PDF from Apple's site). I think you can opt to install only Bonjour without AirPort Utility, but with AirPort Utility it's possible to administer your AEBS using your PC. Another thing I just thought of, you may need to install AirPort Utility from the CD, as the version on Apple's support site may not be the newest version. Hope you get it working.
     
  9. tomes666 macrumors newbie

    Joined:
    May 28, 2012
    #9
    The username is administrator

    I also ran into this problem. Yes, the Airport Utility helps, however there may be cases where you want to use it as a shared network drive and need to configure this with the username/password as per normal. In my case I have a sync software that works better with the share and credentials than with a mapped drive, so I wanted to do it the traditional way.

    The username 'administrator' with the Airport Extreme password worked for me. Gives read-write access. Other usernames didn't work.
     
  10. GOJ macrumors newbie

    Joined:
    Jul 17, 2012
    #10
    Default Username

    This also baffled me!

    The answer is the username can be anything (no spaces) it's the password you need to get right.
     

Share This Page