[HOW-TO] Fix a Bluetooth keyboard that is repeating keys

Discussion in 'iPad Tips, Help and Troubleshooting' started by Jessica Lares, Nov 26, 2014.

  1. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #1
    I have been having a problem with my ClamCase Pro lately since the iOS 8 update. Maybe a few others too? A lot of times when I'd type a letter, it'll get stick and so instead of typing something like "sometimes", I'd end up with "sssssoooomeeeetttimmmes" because the letters would get stuck.

    It puzzled me that just about every letter on my keyboard was having this issue (except the numbers). I have put a lot of miles on it, but it otherwise still looks great.

    Just now I figured out the solution though, and that was to:

    1. Go into Settings, Bluetooth, and then My Devices
    2. Find your keyboard, and then click the information icon on the right (the circle with the letter i)
    3. Click "Forget This Device"
    4. Turn off the keyboard, turn it back on, and then go through the pairing process again

    If there is nothing wrong with the hardware, then you should be back up and running and the problem will be gone.
     
  2. IrishVixen, Nov 28, 2014
    Last edited: Nov 28, 2014

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #2
    Interesting...I have this problem, but it's only coming up when trying to edit in larger documents. Since I was using the original Notebooks for iPad and not the one for iOS 7/8, I figured it was the app, and paid to upgrade that. Didn't work. Unfortunately your fix didn't work either, though I'll probably retry again a few more times.

    It doesn't happen on new docs, or text only ones (so far), just ones that have images embedded with the text. Unfortunately, I've only got the one keyboard to test with, which makes triage difficult for this kind of bug!

    Edit: closing every other app mitigates it somewhat. The lag is still horrendous, but only one doubled letter in a full sentence. Keyboard works fine in the same file on iPhone 6/8.1 JB, so I'm leaning away from a hardware issue. which is a slight bummer as I did want the new Keys To Go to replace it! LOL

    rMini, 8.1.1, Logitech Ultrathin Keyboard Cover (1st mini version)
     
  3. Jessica Lares thread starter macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #3
    I read about someone having this issue on Evernote too. I have a feeling it's an iOS 8 thing. To begin with, the system keyboard kept popping up when I had it connected, but that went away in 8.1 for the most part.

    LOL, yeah, those Keys To Go are very tempting!
     
  4. IrishVixen, Nov 28, 2014
    Last edited: Nov 28, 2014

    IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #4
    Sigh. Exact same thing, very often it takes three or four tries of backing out of the doc (or email, or message) to get the virtual keyboard to quit popping up...still happening here in 8.1.1, even in stock apps like Mail--though the only place I've seen the repeating keys issue was in Notebooks. I think you're right, it's an iOS 8 bug.

    So damn frustrating!

    Edited, in case others need other solutions to try: well, I thought I had the solution in the Apple Wireless Keyboard...worked in that same document OK for a few sentences. Left it, came here to report, went back and boom....repeating letters and sluggish performance.

    It's not wifi related, tested with and without it on, no difference. Kicked all apps out of memory, no change. Grrrr......!

    Edit 2: still more testing. Rebooted iPad. Apple keyboard in same lengthy, image filled document--very sluggish, but no repeated letters. In small, no image doc within same app, a little sluggish, but definitely faster. Back here in this post, keyboard close to being "normal" in terms of speed.

    Turning off other Bluetooth devices, no change in keyboard/iPad response.

    Edit 3: More research. Bug was spotted in iAWriter back in September. In that case, disabling predictive text fixed the issue. (Settings > General > Keyboards, toggle predictive text off).

    Unfortunately, this solution didn't work for me either.

    Edit 4: Two more potential workarounds tested from suggestions elsewhere...turn off split keyboard function, and delete any third party virtual keyboards. Nope, and nope.

    I think I'm done. My only semi-viable workaround at this point seems to be to stick with small files and no images. Which will work for some docs, but not for others.
     
  5. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #5
    Is your "forget this device" trick still working for you? My husband took over my Apple Wireless keyboard and promptly ran into this bug while using Pages. I've been fine continuing to use my "small, text-only docs" trick, but he literally had it happen two paragraphs into typing.

    I sure hope Apple fixes this one in 8.1.3/8.2!
     
  6. Jessica Lares thread starter macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #6
    I only had it happened to me that one time so far.

    I had to send my keyboard in for a warranty claim so am without it at the moment. My power switch fell off since the metal bit was separating from the keyboard.. :eek:
     
  7. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #7
    Good to know that the problem didn't come back, at least. I'll have him try the forget & re-pair routine then.

    Sucks about the Clamcase, but at least it was still under warranty! Hopefully you get it back soon. I did end up with the Keys To Go for Xmas, and it's pretty sweet. Haven't seen the key repeat issue crop with it, but I haven't tried it with my test file yet either. LOL
     
  8. gpotts5626 macrumors newbie

    gpotts5626

    Joined:
    Sep 28, 2015
    #8
    I have a Sharkk keyboard and an iPad Air2. This problem appeared for me with the release of iOS9. Forgetting the device and pairing it again solved the problem.
     
  9. cubeans macrumors newbie

    Joined:
    Mar 5, 2016
    #9
    --- Post Merged, Mar 5, 2016 ---
    Thanks for your post. Had a keyboard case I gave up on almost 6 months ago and this fixed the issue!
     
  10. ToddBradley macrumors newbie

    Joined:
    Apr 13, 2014
    #10
    Here's another THANK YOU for the suggestion. My Anker keyboard/case was doing this the past few days. So I did this trick and now they seem to be happy together again.
     

Share This Page