How to fix Airport Express slow wifi speeds

Discussion in 'Mac Accessories' started by Rangerbob86, May 31, 2013.

  1. Rangerbob86 macrumors newbie

    Joined:
    Apr 18, 2011
    #1
    I have cable internet advertised as 20 - 30 Mbps, and a Surfboard SB6120 modem. When I plug directly into the modem, I get around 28 Mbps and am very happy with that. When I go into the Airport Express however, it slows to around 8 Mbps. The airport express is from 2009. I have tried changing it to only 802.11n (have trieed both 2.4 and 5 ghz options), and have tried changing the channel, but nothing seems to help. Is there a way to get it back up to around 28 Mbps, or do I need a new router? Thanks!
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    OPTION/Alt click on the WiFi/AirPort icon in the Menu Bar and tell us what it says after
    • Channel
    • PHY Mode
    • Transmit Rate
    .

    [​IMG]
     
  3. Rangerbob86 thread starter macrumors newbie

    Joined:
    Apr 18, 2011
    #3
    With everything set to automatic, I get:

    PHY Mode: 802.11n
    Channel: 1 (2.4 GHz)
    Transmit Rate: 65

    If I set it just to 5 GHz, I get:

    PHY Mode: 802.11n
    Channel: 161 (5 GHz)
    Transmit Rate: 135
     
  4. lemond68 macrumors newbie

    Joined:
    Jun 9, 2013
    #4
    someone recommended changing your firmware on your airport express back to the 7.6.1 it worked for me (for about 1 hr for others it has been a stable fix)
     

Share This Page