How to fix automatic url filling?

Discussion in 'Mac Basics and Help' started by hajime, Oct 13, 2012.

  1. hajime macrumors 68030

    Joined:
    Jul 23, 2007
    #1
    Hello, since I used a free wifi service in a mall few days ago, whenever I type "www.yahoo.com", FireFox changes it to "https://www.yahoo.com" automatically. This results in "Your requested URL was not found." I have to manually remove the 's' behinds 'http'. Is there a way to fix this problem? Thanks.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    I believe you should be able to do this by deleting history. There are a number of things the browser can delete for you including cookies, history, etc but deleting cookies logs you out of any sites you have set to "stay logged in" so I'd start by deleting history for the last couple of days rather than going any further. Also the https setting might not be the browser's fault. Yahoo may have a setting to "always use ssl" but I'm puzzled why you would want to change it in the first place.

    I just tried going to https://www.yahoo.com and yahoo used a feature called "url fixup" (that happens on the server) to switch it to plain old http://www.yahoo.com. So I don't think the browser or OSX is the only place to look for a solution to this.

    I have found yahoo to be a bit of a snake pit. I have a friend who has had their yahoo account taken over by hackers and yahoo was clueless, slow and unhelpful getting her account back. It doesn't help that the default email provided to at&t dsl and uverse users is via yahoo. I prefer gmail or even hotmail (or whatever it's called these days) over yahoo for email. Flickr is another story. It's a very good service but again the customer support is somewhere between non-existent and clueless.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    "Hello, since I used a free wifi service in a mall few days ago, whenever I type "www.yahoo.com", FireFox changes it to "https://www.yahoo.com" automatically. This results in "Your requested URL was not found." I have to manually remove the 's' behinds 'http'. Is there a way to fix this problem?"

    Safari does this, too. Apparently some software designers think that by "autofilling", they're trying to be helpful, when for some users (myself included) this is positively confounding.

    There's no way to "turn it off", that I know of.

    There -IS- a workaround. Do this:
    BEFORE you begin typing the URL, type one (or two) "space characters", and then type your URL into the bar.
    Any better?
     
  4. Efrem macrumors member

    Joined:
    Jul 30, 2009
    #4
    In Firefox, try this:

    Open Preferences.

    Select the Privacy section.

    At the bottom, after "When using the location bar, suggest:," choose "Nothing" (or "Bookmarks," if you haven't bookmarked the location you don't want) from the pull-down menu.

    Please let us know if that solves your problem.
     
  5. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007
    #5

    It is working. Thank you very much!
     

Share This Page