How to fix Blue Hue problem?

noodile

macrumors regular
Original poster
Aug 4, 2012
139
0
I searched the forum but couldn't find how to fix it. On my brand new 2012 MBP, everytime graphics switching kicks in, i get a "blue Hue" on the screen. its starting to get on my nerves now. anyone know how it can be fixed?


Edit: 15" High-res antiglare screen
 

Yzerweed

macrumors newbie
Aug 17, 2012
1
0
I have the same problem. What i always do is logout then re-login to get rid of the "blue hue". I don't think there's a permanent solution to this
 

noodile

macrumors regular
Original poster
Aug 4, 2012
139
0
I think the color profile gets applied to everything. i just want it applied to one graphics card. the issue only happnes when i use graphic intensive applications.
 

willsoriano

macrumors member
Mar 21, 2011
39
0
I recently bought a new 2012 non retina mbp 2.6 with an lg display that does the very same thing. It's annoying and actually made me realize that this display isn't as good as the late-2011 I had before this.

This newer display/refresh/whatever the cause me be doesn't have that same crisp clear don't have to mess with profiles look. I don't know if I should goto the apple store and try and have it replaced (they've always been really uncooperative with replacements and repairs with my iPhone).

Does anyone know what the apple stores standard is for issuing replacements and repairs for the mbp display is so I don't have to go though the whole parade of "that's normal and to be expected regardless of the fact that every model we have on display here doesn't have that issue"
 

Fry-man22

macrumors 6502
Nov 25, 2007
453
10
I think the color profile gets applied to everything. i just want it applied to one graphics card. the issue only happnes when i use graphic intensive applications.
When it changes to the blue cast you should go reselect your color profile. I have had instances in the past where my color profile would go on and off. I never thought to associate it with the GPU switching, but that is very well what it could have been.

Instead of logging out and back in next time, maybe try opening the display prefs and unselecting and then reselecting the color profile you run day to day.
 

noodile

macrumors regular
Original poster
Aug 4, 2012
139
0
well, finally figured out how to fix it thanks to you guys.


Go into energy saving >> Disable automatic graphic switching (basically force it on invidia)


Then go into displays >>> color >>> choose your favorite. (I chose color match RGB and that worked perfect for me).


Now go back into energy savings >>>> enable graphics switching >>> and you're done. (you might need to double check the color settings again)

----------

I recently bought a new 2012 non retina mbp 2.6 with an lg display that does the very same thing. It's annoying and actually made me realize that this display isn't as good as the late-2011 I had before this.

Try what i did and lemme know if it works for you.

----------

I have the same problem. What i always do is logout then re-login to get rid of the "blue hue". I don't think there's a permanent solution to this

Just fixed it. works good now, and settings stay the same even after a restart.