Resolved How to fix boot/recovery loop and restoring errors 21, 1600, and 1601

Discussion in 'Jailbreaks and iOS Hacks' started by Tiltzor, Mar 6, 2013.

  1. Tiltzor macrumors newbie

    Joined:
    Mar 6, 2013
    #1
    First off I have a GSM iPhone 4 running 6.0.1 during the boot/recovery/respring loop and 6.1.2 for the restoring errors. I'm sure that this works for any ios above 6.0.0 but below that i have no promises, also I've been using evasi0n jailbreak.

    Alright if you're anything like me you didn't panic during these situations but rather went straight to google, i use a mac so anyone running a pc (though im sure it'll work) im not sure if any pc exclusive programs will do the job. Anyways i tried everything and i mean every single thing i could read up on or watch, downloaded countless numbers of programs and guess what... NOTHING. So after hours to fix each here are my simple and hopefully helpful resolutions. Ill start with the boot loop but it that doesn't concern you scroll down to see the restoring errors resolution.

    For all of these you will need the latest version of itunes.

    How to fix a boot, restore and respring loop:

    Most likely you encountered this issue from installing a infected package and it must be deleted. For this im going to skip all the simpler solutions that MAY work and go straight to what i know will work remember this WILL clear your idevice of your jailbreak packages but will not unjailbreak it, that can be done after but only use this method if nothing else will work this is not a first resort solution.

    Step 1: Download iexplorer for mac or pc. http://www.macroplant.com/iexplorer/?utm_expid=15979170-15&utm_referrer=https://www.google.com/ if this doesnt work just google iFunbox and use that program remember don't buy the programs just use the demo.

    Step 2: This step will take some time so be patient... using iexplorer open up you phones media files and delete EVERYTHING that you knows 100% has to do with jailbreaking i.e. cydia, evasi0n, tweaks. Do NOT just delete things aimlessly that can cause phone damage just delete as much as you recognize and hope its enough and remember to go through ALL the files, it'll take awhile but its worth it to save your device.

    Step 3: Open Evasi0n and rejailbreak, Evasion says its not smart but in this case you should, do NOT go through all the steps though, once your device has been turned back on and evasi0n asks you to click the jailbreak icon on the homepage do not do it. Unplug the device and continue through the steps.

    Step 4: Open itunes on a separate computer and locate the device in it and restore, this will restore your device completely, you may have noticed from the last step that even though you are technically jailbroken you do not have cydia. This removes all jailbreaking data and is required to rejailbreak or restore/update in the future.

    At this point your device is back to normal and can be used, if you dare you can rejailbreak but remember by restoring your device your firmware has been updated to the latest.

    How to fix your device if when attempting to restore you see error 21, error 1600 and or error 1601.

    All of these errors happen because you have tried to unjailbreak your device using the restore method on itunes and most likely had to fix a boot loop in the past or are just experiencing common issues. Most forums tell you to download a program and change the host, well if your like me you tried that... it didn't work, so heres my solution.

    Step 1: On you computer locate the /private folder on a mac you click on the desktop which changes your current application to Finder and then in the status bar above locate "Go" 5 options in not including the apple logo. Do the version of this on pc, sorry for not knowing but google how to locate /private on pc if you dont know how, from step 3 on is universal.

    Step 2: Once you have clicked on "Go" scroll down and click on "Go to folder..." in the window that pops up delete all existing text and insert /private and click Go

    Step 3: Click the folder etc and remember at any point if it asks you to type your password, do it.

    Step 4: Locate the hosts file not hosts.umbrella just hosts

    Step 5: Drag this file onto your desktop which therefore will make a copy.

    Step 6: Right click the desktop hosts file, right click or control click and open with Textedit(mac) or Notepad(pc)

    Step 7: Scroll all the way down to the bottom and locate where it says "74.208.10.249 gs.apple.com"

    or

    "74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com"

    Step 8: Highlight all the items you see from above (either just line 1 or both line one and 2 depending on whichever your computer has)

    Step 9: First i suggest you copy the text before deleting it after that delete the newly highlighted text

    Step 10: Save the new file overriding the old one

    Step 11: Drag and drop the desktop hosts file into the etc folder and click authenticate and type in your password

    Step 12: Close Finder and open itunes which should recognize your device in recovery mode (if not just unplug and plug back in) after you should see the restore required message, go ahead and restore and after a few minutes WALA its good.

    Make sure to tell me below whether or not it worked for you, i know trouble solving yourself is tough and since if found alternate ways for both of these seemingly common issues i decided to sare it also share anything that worked for you!
     
  2. UnitZero macrumors newbie

    Joined:
    Oct 3, 2013
    #2
    Hi

    Hi, I have a 4s and my cellphone is stucked in recovery mode, Ive tried to restore, but I get errors always (29, 27 etc.) Ur program doesnt recognize my iDevice.

    This is what I get when trying to use TiniUmbrella
    10/04/2013 00:24:15.046 Recovery Device disconnected: null 10/04/2013 00:24:20.578 Recovery Device connected: 10/04/2013 00:24:21.140 Recovery Device disconnected: null 10/04/2013 00:24:26.703 Recovery Device connected: 10/04/2013 00:24:33.718 Recovery Device disconnected: null 10/04/2013 00:24:39.234 Recovery Device connected: 10/04/2013 00:24:39.781 Recovery Device disconnected: null 10/04/2013 00:24:59.031 Recovery Device connected: 10/04/2013 00:25:01.390 Recovery Device disconnected: null 10/04/2013 00:25:06.937 Recovery Device connected: 10/04/2013 00:25:07.546 Recovery Device disconnected: null 10/04/2013 00:25:13.046 Recovery Device connected: 10/04/2013 00:25:13.625 Recovery Device disconnected: null 10/04/2013 00:25:19.281 Recovery Device connected:

    This from RecBoot
    recovery_connect_callback
    recovery_disconnect_callback
    recovery_connect_callback
    recovery_disconnect_callback
    recovery_connect_callback
    recovery_disconnect_callback
    recovery_connect_callback
    recovery_disconnect_callback
    recovery_connect_callback
    recovery_disconnect_callback

    Over and over again, I'm tired of this, I need help to solve this. :(
     
  3. Abba 701 macrumors regular

    Joined:
    Jun 17, 2012
    #3
    Hmm.maybe try a hard reset? Try to put it in DFU mode also.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    To threadstarter:

    Or you could of just used iLEX RAT and been done in 4-5 minutes with a clean phone, still on same firmware.

    ----------

    A 4S can only be restored to current firmware.
    Use iTunes, not TinyUmbrella.
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    Original post was in march, I don't think ilexrat was out yet at the time, or least, not as known
     

Share This Page