Resolved How to fix dpkg files Cydia problem

Discussion in 'Jailbreaks and iOS Hacks' started by BISHOPSCM1000, Apr 2, 2014.

  1. BISHOPSCM1000 macrumors newbie

    Joined:
    Apr 2, 2014
    #1
    Recently many people have been having problems in Cydia with it not being able to refresh and instead getting the error such as "couldn't configure pre-depending dpkg for ncursers, probably a dependency cycle" or many other errors.. Here is how to fix it! Running iOS 7!

    - Need another jailbroken device that is running with no errors to do this!
    - Need iFile on both devices!

    1. On your jailbroken device (broken Cydia device) that has iFile, go to /var/lib and delete the file labeled dpkg.
    2. Now on your other device that works go to /var/lib press "edit" and select the file named dpkg and then select at the bottom (2nd option) the picture with a file with an arrow pointing down and create the ZIP labeled dpkg.
    3. From there, select the new ZIP file you just made and mail it to yourself from iFile by pressing (4th option) the mail logo.. (After the email is sent you may delete the ZIP file.)
    5. That's all you need to do with the working jailbroken device...
    6. On your non-working device go to your mail and find the email you just sent yourself.. find the ZIP file you sent and hold it down. it will ask what you would want to open it in. Select "iFile".
    7. From iFile, select "Unarchiver" and let it do its thing.
    8. From there, select the blue file that IS NOT ZIP! (Should be probably be the 5th one down). Select the (6th option) that looks like a clipboard on iFile and select "Cut"
    9. From there, go back to /var/lib, press "Edit" then the clipboard again and select "Paste"
    10. Done! Now re-boot your device and refresh Cydia.
     

    Attached Files:

  2. pati78 macrumors newbie

    Joined:
    Apr 5, 2014
    #2
    Dpkg

    Please some1 help me,
    I have the same error but the problem here is that I don't have Ifile installed,
    I have tried lots of other programs such iexplorer but I cannot ssh my iphonefoleders
    please help me out
     
  3. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    You would need to had either installed openssh or afc2add beforehand

    All those programs you mentioned use afc2add
     
  4. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #4
    Darrick is right. You need to have installed at least one of the two packages in order to access file system via USB cable or SSH.

    Any chance you have iCleaner installed? You can try that. It has an option to fix Cydia sources. Not sure it'll work but worth a shot.
     
  5. pati78 macrumors newbie

    Joined:
    Apr 5, 2014
    #5
    Hey Darrick,

    First I wanna thank you for you time,

    Is there anyway I can install openssh now because I don't have it?:confused::confused::confused::confused::confused::confused::confused:

    Thank you in advance

     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    Other than installing it from cydia, I think you're out of luck
     
  7. superdoido macrumors newbie

    Joined:
    Apr 12, 2014
    #7
    Help

    Could you post the file dpkg working? I do not have anyone working with jailbreak to achieve.

    My IOS 7.04 Iphone 5

    Thanks
     
  8. zerotype2 macrumors newbie

    Joined:
    Jun 17, 2014
    #8
    I have the same problem. Can someone send me dpkg pls. Here is my email jnvc013@gmail.com

    I'm on 7.0.6
    Cydia ver: 1.1.12


    Thanks in advance
     
  9. Mafiarulz007 macrumors newbie

    Joined:
    Jun 9, 2014
    #9
    Actually by mistake i deleted all the folders in the "lib"
    And now when I try to install cydia from deb file it gives me missing dpkg error
     

    Attached Files:

  10. Mafiarulz007 macrumors newbie

    Joined:
    Jun 9, 2014
    #10
    See all folders r missing from "lib"
    I would really appreciate if u could send those folders with files to me
    I dont care abt packages and sources just want cydia to work without loosing 6.1.3 :(
    Email Id is : mafiarulz007@gmail.com
     

    Attached Files:

  11. Quinten101 macrumors newbie

    Joined:
    Nov 16, 2014
    #11

Share This Page