How to fix MacBook Air internet speed?

Discussion in 'MacBook Air' started by CableDog, Oct 4, 2013.

  1. CableDog, Oct 4, 2013
    Last edited: Oct 10, 2013

    CableDog macrumors newbie

    Joined:
    Oct 4, 2013
    #1
    I found the answer.

    Log-on to your router, go to the Application and Gaming Tab, click on the QOS tab and then disable WMM support

    Credit goes to Resqu2 for that solution.

    Thanks goes out to everyone on this thread who helped me
     
  2. Miltz macrumors 6502

    Joined:
    Sep 6, 2013
    Location:
    New York
    #2
    Have you tried doing a recovery? I'm not sure on macs, but overall I've never seen a wireless card go bad in all my years using them. From 802.11a to 802.11ac.
     
  3. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #3
    OK before we spend time asking you lots of redundant questions, what trouble shootings have you done so far? Go from there.
     
  4. octatonic macrumors regular

    octatonic

    Joined:
    Mar 23, 2010
    Location:
    London
    #4
    I had a 2012 MBA that started losing internet connection periodically and was running slow.

    The solution was a full OSX reinstall- fixed it straight away.
    It is probably software, not a hardware issue.
     
  5. CableDog, Oct 5, 2013
    Last edited: Oct 5, 2013

    CableDog thread starter macrumors newbie

    Joined:
    Oct 4, 2013
    #5
    I've tried updated the OS but even that didn't work.

    I also tried the SpeedTest website and got download speeds of less than 40kb/s and upload speeds of more than 6mb/s

    I have a linksys e1200 router

    the internet runs fast on other devices (pc, iPhone) just not the MBA.

    I find it extremely puzzling and have no idea why that is

    Some more information
    IPv4 Address: 192.168.1.139
    Subnet Mask: 255.255.255.0
    Router: 192.168.1.1
    Configure IPv6: Automatically

    DNS Servers
    75.75.75.75
    75.75.76.76
    192.168.1.1
    Search Domains: hsd1.il.comcast.net

    MAC Address: 00:88:65:43:5c:82

    And I've only used 40 of the 60 GB available
     
  6. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #6
    Assuming you have not withheld any pertinent information like, uh I had a liquid spill incident a few months ago... or it started to happen when I upgraded the router...

    I would install OSX from scratch, clean. Yes it's a major hassle, you will have to re-install all your apps, save and restore data.
     
  7. CableDog thread starter macrumors newbie

    Joined:
    Oct 4, 2013
  8. cbautis2 macrumors 6502a

    Joined:
    Aug 17, 2013
    #8
    Throw away your e1200 and get the latest Apple airport extreme (802.11ac) then problem solved.
     
  9. Thraun macrumors regular

    Thraun

    Joined:
    Dec 18, 2008
    Location:
    Abbotsford, BC
    #9
    A couple solutions have been suggested, eg reinstalling the OS. You also haven't responded with the troubleshooting steps you've gone through, if any.

    Have you tried making a different user account and testing the internet there, or booting into safe mode? Try adding a new location in your network settings and testing that as well. I don't suppose you have a thunderbolt-Ethernet adapter; if you did, you could hardware your connection and test it.
     
  10. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #10
    U mean like something for sure to fix it? No such thing exist in the computer world. All you can do is narrow down the cause(s) and sometimes, there are just too many variables, so OSX re-install cover all software cases, unless you really have a hardware problem.

    I forgot, do SMC reset, and recently there is a post of somebody having a similar problem with Safari, but everything else works, and accordingly to him it was an ISP problem. Why would the ISP discriminate Safari only beats the heck out of me.

    No magic.
     
  11. CableDog, Oct 9, 2013
    Last edited: Oct 9, 2013

    CableDog thread starter macrumors newbie

    Joined:
    Oct 4, 2013
    #11
    Still can't solve it!

    I tried reinstalling the OS but even that didn't work.

    I'd like to know some other ideas

    I want to know what's causing this problem

    Are there any settings I can fix or change or look into?

    what about logging into the router?

    channel width?

    I know there are a lot of experts here that can help me
     
  12. davecom macrumors member

    Joined:
    Aug 10, 2009
    #12
    Did you try running speedtest on the other devices at the same time of day? Are you sure they are all connected to the same Wireless network?. Is the SSID exactly the same?
     
  13. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #13
    have you tried your air on another wifi network?


    you reinstalled the OS and still see this problem? take it to the apple store.
     
  14. calvol, Oct 10, 2013
    Last edited: Oct 10, 2013

    calvol macrumors 6502a

    Joined:
    Feb 3, 2011
    #14
    Try this > turn off iPv6 under the Networking TCP/IP prefs.

    This same thing happened to me with a 2010 Air running Snow Leopard 10.6.8., getting half the download speeds on speedtest as my Dell laptop.

    In my case, this evidently is an Ethernet stack iPv6 issue on this version of OSX, not a WiFi issue, where the iPv6 translation is slowing the throughput speeds. I am betting your setup is related to this protocol issue, either on your router or your Mac.

    Always check the Apple support forums for these types of issues, they have many more posts. That's where I found the idea to turn off iPv6.
     
  15. MikePembo951 macrumors member

    Joined:
    May 25, 2013
    Location:
    UK
    #15
    I had the exact same problem just a few days ago!

    I have a few suspicions:
    1) My router
    2) Time Machine (I back up over wifi to NAS)
    3) Could possibly be OSX or my macbook (but I certainly hope not!)

    I've only noticed it happen maybe once or twice in the past week (and I've been using this macbook on average 6 hours a day for the past few months since I bought it), and has only been happening recently.

    Screenshots follow
     

    Attached Files:

  16. CableDog thread starter macrumors newbie

    Joined:
    Oct 4, 2013
    #16
    Alright guys, I just ran speedtest.net using Google Chrome browser. Here are the results

    Ping: 15ms
    Download: 0.73 Mbps
    Upload: 5.23 Mbps

    One of the things I don't understand is why the upload speed is always so much higher than the download speed.

    I'm trying to find the cause of this problem. Here's what I know though

    It's not the router. My network runs fast on all other devices
    It's not the OS. I just reinstalled OSX the other day

    I just logged into the router (192.168.1.1)

    I believe with that I can figure some things out

    I think one of the posters suggested to disable IPv6. Is this a good idea?

    On my router, under the setup tab, there is a subtab labeled IPv6 Setup. Under there the options are

    IPv6 - Automatic * Enabled * Disabled
    DUID 00:03:00:01:20:aa:4b:06:f9:4a

    Another tab is wireless. Here are the options on that tab

    * Manual *Wi-Fi Protected Setup
    Network Mode Mixed
    Network Name Cisco51981
    Channel Width Auto (20 MHz or 40 MHz)
    Channel Auto
    SSID Broadcast * Enabled * Disabled

    Under wireless security, the security mode is WPA2 Personal

    Under the guest access tab, the options are

    Allow guest access *yes * no
    Guest Network Name Cisco51981-guest
    Guest Password guest
    Total Guests Allowed 5
    SSID Broadcast * Enabled * Disabled

    Under the Security Firewall tab, I have the following options selected

    IPv6 SPI Firewall Protection: * Enabled * Disabled
    IPv4 SPI Firewall Protection: * Enabled * Disabled

    Filter Anonymous Internet Requests
    Filter Multicast
    Filter Internet NAT Redirection for IPv4 Internet Only
    Filter IDENT (port 113)

    * Proxy * Java * ActiveX * Cookies

    Under VPN Passthrough, I have the following selected

    IPSec Passthrough * Enabled * Disabled
    PPTP Passthrough * Enabled * Disabled
    L2TP Passthrough * Enabled * Disabled

    I have the following ports opened

    External Port Internal Port Protocol To IP Address
    53 53 Both 192.168.1.50
    80 80 Both 192.168.1.50
    88 88 Both 192.168.1.50
    1863 1863 Both 192.168.1.50
    3074 3074 Both 192.168.1.50

    Under the Administration Management Tab, I have the following options selected

    Access via * HTTP * HTTPS
    Access via Wireless * Enabled * Disabled
    Remote Management * Enabled * Disabled
    Access via * HTTP * HTTPS
    Remote Upgrade * Enabled * Disabled
    Allowed Remote IP Address Any IP Address
    Remote Management Pot 8080
    SIP ALG * Enabled * Disabled
    UPnP * Enabled * Disabled
    Allow users to configure * Enabled * Disabled
    Allow users to disable * Enabled * Disabled
    internet access

    I'd really like to figure out how to fix this

    Anyone have any ideas?
     
  17. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
    #17
    Its the router I bet

    I had the exact same problem on my IPad, google it, slow IPad wifi. I had to disable something called QOS or quality of service, there is another name also for different routers but I have a Linksys. I disabled it and my problem went away instantly. I was also getting great uploads but real bad DL speeds.

    If you can't find what I'm talking about let me know and I'l dig up more info for you.

    edit to add, in the router set up look for applications and gaming, the under that tab look for QOS then under that I have WMM support, disable this and restart everything, this is an important step. afterward, problem solved.
     
  18. CableDog thread starter macrumors newbie

    Joined:
    Oct 4, 2013
    #18
    It looks like you were spot-on. I disabled it and the internet speeds increased to 30 MBPs

    I'm going to test the internet some more but so far it looks really promising.

    Thank you very much
     
  19. calvol macrumors 6502a

    Joined:
    Feb 3, 2011
    #19
    I suggested disabling iPv6, but it's not a long-term solution. Just do it on your Air only, and see if the download speeds go up for my own curiosity. Your problem is probably different than mine because I'm running Snow Leopard, and it's something Apple fixed in Lion and ML, because my Mac Mini running ML does not have this issue.
     
  20. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #20
    Glad u got it worked out.

    Now this QOS/WMM business is designed to give priority to those connections which are doing audio/video streaming, like Netflix. If all of a sudden your media streaming are having problems, u will remember this.
     
  21. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
    #21
    Is this a Linksys issue or do all modems have this? It almost made me want to throw my IPad away until I figured it out, weird that it didn't affect my 2 IPhone 5's or my Macbook Pro or my IMac. BTW I don't do any streaming at all so that wasn't causing an issue, it killed my IPad speed all the time.
     
  22. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #22
    All new routers will have something like this, although they may call it by different names.

    Odd that it only affects the iPad, but my experience, router vendors throw these "features" out without fully testing how they function in real life.

    Good thing is, you can turn it off. It should come turned off out of the box, but am not going to vouch for today's QC.
     
  23. stylinexpat macrumors 6502a

    Joined:
    Mar 6, 2009
    #23
    Is this supposed to provide priority if more then 1 person is connected or even if just 1 person is connected?
     
  24. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #24
    Technically, if only a single user on the LAN, nothing should happen, but as mentioned, I won't vouch for different's vendors' implementations.
     
  25. bosxfan1 macrumors newbie

    Joined:
    Sep 16, 2013
    Location:
    Virginia
    #25
    It seems to be more of a problem with Linksys. I have a 1500 the had this problem after a firmware update. Lots of documentation on the Interwebs about this.
     

Share This Page