How to fix the Guest account ...

Discussion in 'Mac Basics and Help' started by rjalex, Mar 29, 2011.

  1. rjalex macrumors newbie

    rjalex

    Joined:
    Mar 27, 2011
    Location:
    Rome, Italy
    #1
    Dear friends,
    longtime unix and win user, recently switched at home to Mac 10.6.6 and VERY happy about it.

    I have moved applications in the Applications folder from the flat structure they originally had to a hierarchical one (I like my applications to live in "communication", "multimedia", "system" and "games/applications" subfolders.

    Aside from having to fix little snitch rules my usual user works as a charm.

    When I switched to the Guest account (I use that for people coming to my place as guests) I found almost (finder, dashboard and application folders are ok) all of the Dock applications replaced by question marks. I think this is probably because of the applications paths having changed but how can I fix this being into the Guest account ?

    Another behaviour I cannot quite explain is that in this "corrupted" environment I tried navigating to the Application folder and dragged Safari on the Dock but when I launch it it does not seem to be connecting at all.

    I tried creating a new user and saw the new Dock being created with the question marks, so I am guessing there is a "template" pointing to the original location of the applications.

    Thank you for any help
    Bob
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    OSX is based on BSD Unix. So with applications keep them in the main applications window. When you make a new folder for application make those folder in the Main Applications folder.
     
  3. rjalex thread starter macrumors newbie

    rjalex

    Joined:
    Mar 27, 2011
    Location:
    Rome, Italy
    #3
    Thank you satcomer but I do not think I understand you.

    I have created 4 subfolders in the /Application folder and all seems to work well BUT probably the Guest user Dock is built from a template which points to the original paths.

    I have created a template for new users which is exactly what I need and now when I create one I get the Dock I want but for some reason the Guest user keeps on having the same "default" dock which is now full of question marks.

    Any help ?

    Thanks
     

Share This Page