How to force ATV 2 to resync My Movies?

Discussion in 'Apple TV and Home Theater' started by eddyg, Mar 10, 2008.

  1. eddyg macrumors 6502

    Joined:
    Sep 5, 2003
    Location:
    Christchurch, New Zealand
    #1
    Hi,

    On innumerable occasions my ATVs running 2.0 are displaying out of date My Movies content (due to my tagging, renaming, deletions, additions etc). The data is permanently out of sync.

    With ATV 1.* I would disconnect and reconnect to iTunes and ATV would clear its cache and be up to date again.

    Is there a simple solution for ATV 2.0?

    So far a power cycle is the easiest solution, and I don't like that. Disconnecting from that iTunes and reconnecting is not a workable solution with ATV 2.0 since you have to re-pair the ATV and iTunes.

    Cheers, Ed.
     
  2. AliensAreFuzzy macrumors 68000

    AliensAreFuzzy

    Joined:
    May 30, 2004
    Location:
    Madison, WI
    #2
    In iTunes, right click on the :apple:TV and select sync.
     
  3. eddyg thread starter macrumors 6502

    Joined:
    Sep 5, 2003
    Location:
    Christchurch, New Zealand
    #3
    That will update the information that is "synced" to the ATV, but won't update all the information about the streamed content that the ATV has cached.

    i.e.

    The My Movies list text is updated, but the artwork will not be updated to reflect what is in my iTunes Movies list.

    But I am happy that your solution does update the titles and the descriptions - which is a start. Now if only the ATV would clear it's cached artwork as well.

    Cheers, Ed.
     
  4. Roy Hobbs macrumors 68000

    Roy Hobbs

    Joined:
    Apr 29, 2005
    #4
    A manual sync as stated above will update info that is streamed as well as synched
     
  5. eddyg thread starter macrumors 6502

    Joined:
    Sep 5, 2003
    Location:
    Christchurch, New Zealand
    #5
    Not the artwork that has been cached prior to that point. I.e. if you have ever selected that movie in the past - then change the artwork in iTunes - you can't get that artwork onto the ATV (as far as I can tell).
     
  6. MikieMikie macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #6
    Eddy,

    The bad news is the only way I have made this happen is from the iTunes side. I've had to delete all my (non-synced) movies and then re-add them.

    [HEAVY SARCASM]I just love v 2.0[/HEAVY SARCASM]

    Wishing I could go back to 1.1
     
  7. eddyg thread starter macrumors 6502

    Joined:
    Sep 5, 2003
    Location:
    Christchurch, New Zealand
    #7
    Resetting the ATVs cleared the artwork caches and they were back in sync.

    Cheers, Ed.
     
  8. DataThief macrumors member

    Joined:
    Jul 30, 2007
    Location:
    Somewere in Washington State
    #8
    I did go back to 1.1 (factory reset) it's been working a lot smoother since. I was having problems with it loosing connection to my library and forgetting my wireless settings.
     
  9. Axegrinder macrumors regular

    Axegrinder

    Joined:
    Jun 1, 2006
    Location:
    Preston
    #9
    I got so p*ssed off :mad: with all the various syncing issues as mentioned here that last week I downgraded to 1.1 thinking things should be better but I still had issues such as artwork not changing, or having to re-enter the iTunes pass number every bloody day, etc.

    I was convinced the wireless connection was part of the problem. In the end I ran an ethernet cable from upstairs to downstairs so I could connect my mac directly to my router (and my Apple TV directly to the router as well) and now everything is cured. I upgraded back to v2.0 and haven't had a single problem since, and my god it is fast. The Apple TV is so responsive now, it's unbelievable! The difference is staggering.

    If you're having any issues at all I recommend you at least try directly connecting just to see if your problems are cured. Once I was happy that mine was working as it should, I made the effort to run the cable through the walls. Glad I did, it's a joy to use now.
     
  10. MikieMikie macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #10
    Unfortunately, there's no way back to 1.1 for me. Just 1.0. If I do a factory reset I end up back at 1.0, and then next upgrade skips 1.1.

    Most of my problems are AirDisk, AEBS, iTunes related, and the way in which V 2.0 interacts with those elements.

    I have found a way to keep everything in equilibrium, and though it is not the way I would like things configured, it is stable.

    And my :apple:TV is wired to the AEBS.
     
  11. RumMunkey macrumors 6502a

    RumMunkey

    Joined:
    Nov 3, 2006
    Location:
    Canada
    #11
    When I make changes to my library, I just quit iTunes (with the tv still on -I rarely turn it off), wait a few seconds then re-start iTunes.

    This seems to encourage the tv and iTunes to talk to each other and update any changes to my library.
     
  12. ibglowin macrumors regular

    Joined:
    Jul 1, 2005
    #12
    Try connecting to another source if you have one

    I have been reripping my movies into 5.1 audio the past few weeks now. If you have more than one source that the :apple:TV can stream from just point it to that source for a few seconds and then switch it back to your movie source and it will re-sync and all when be updated.
     

Share This Page