How to "force" refresh of network computers to see shared folders from Win machines?

Discussion in 'Mac OS X Lion (10.7)' started by timidhermit, Dec 21, 2011.

  1. timidhermit macrumors regular

    Joined:
    Jul 6, 2011
    #1
    My MacBook Air 2011 model is connected to my home network that are populated by Windows machines running Windows Vista or Windows 7.

    The problem I have is that when I review Network on my Mac Finder, it takes a long time before those machines will appear. Once appear, I can access the shared folders normally.

    However, I can't find a find to force a manual refresh of the Network on Finder so that the networked computers will show up immediately (like Refresh in Networks in Windows Explorer).

    I read many thread on pre-Lion machines that pre-Lion systems have lots of trouble "discovering" NTFS based machines on a network. But I can't find any info on Lion systems.

    How do I do this on Mac Lion?
     
  2. prisstratton, Dec 22, 2011
    Last edited: Dec 22, 2011

    prisstratton macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
    #2
    I have a workaround that I use for the same situation.
    Install LanScan from the app store and use it to obtain IP addresses for the computers on your network. Then in Finder >> Go >> Connect to server (or just use Command-K). Enter the IP address after the SMB://

    For example: SMB://192.168.1.100

    LanScan has a built in vendor listing that can identify the network cards in different computers and can help to point you at the one you wish to connect to.
     
  3. timidhermit thread starter macrumors regular

    Joined:
    Jul 6, 2011
    #3
    What is the default timing (or timeout) that Lion uses to search for another computers on the network? Somehow, I have a suspicious feeling that NTFS machines are discovered far slower than Macs.

     
  4. prisstratton macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
    #4
    I did some reading and this appears to be an ongoing issue. I tried several tips and the following worked well for me. I made the change and then turned on a Windows PC on my network and it appeared in Finder almost instantly.

    Go to System Preferences >> Sharing - check the file sharing box, then click options and check the box "Share files and folders using SMB".
     

Share This Page