How to get Apple wireless Keyboard and Mouse to remain connected in Windows 7?

Discussion in 'Windows, Linux & Others on the Mac' started by jaybar, Dec 6, 2009.

  1. jaybar macrumors 6502

    jaybar

    Joined:
    Dec 11, 2008
    #1
    Hi

    I cannot get my apple wireless magic mouse and keyboard to remain connected in Windows 7 via boot-camp 3. I have tried the windows generic drivers and the apple drivers to no avail.

    I am running the 32 bit commercial version and not a RC. I have a 2008 Mac Mini.

    Can anyone suggest what I should be doing that I may not be? Can anybody outline the steps that have gotten the keyboard and mouse to be installed, paired and remain connected with the 32 bit comercial version of Windows 7?

    Thanks

    Jay
     
  2. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #2
    My Bluetooth Logitech mouse seems to lose connection with Windows 7 quite a bit; really annoying to have this happen when you're in a middle of a game. :(
     
  3. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #3
    Logitech sucks thats why. Either way, I never received any problems like losing connection on Windows 7. Maybe try repairing? It took a fair few times for Windows to recognize and pair my keyboard/mouse but once it did, the connection was solid.
     
  4. joudbren macrumors regular

    Joined:
    Apr 13, 2007
    Location:
    Edmonton, Alberta, Canada
    #4
    One thing you can try (and no guarantees that it will help) is to disable the power management stuff under the bluetooth section in Device Manager. Make sure that "Allow the computer to turn off this device to save power" is unchecked. Other than that I got nothin'. This kind of stuff is pretty much going to be luck of the draw until Apple officially supports Win7. Cheers!

    James
     
  5. dpl macrumors newbie

    Joined:
    Dec 18, 2009
    #5
    Problem solved!

    One thing you can try (and no guarantees that it will help) is to disable the power management stuff under the bluetooth section in Device Manager. Make sure that "Allow the computer to turn off this device to save power" is unchecked. Other than that I got nothin'. This kind of stuff is pretty much going to be luck of the draw until Apple officially supports Win7. Cheers!

    joudbren was right. This settle it for good! Thanks!
     
  6. darkus macrumors regular

    Joined:
    Nov 5, 2007

Share This Page