how to get dictator to rip with handbrake?

Discussion in 'Apple TV and Home Theater' started by Rjensen, Aug 13, 2012.

  1. Rjensen macrumors newbie

    Aug 13, 2012
    having problem with my copy of dictator usa, handbrake new version does not work exits right quick

    many others tonight worked fine dictator does not :(

    can someone please give me a hand
  2. heisenberg123 macrumors 603


    Oct 31, 2010
    Hamilton, Ontario
    This has happened to me some movies are just a pain
  3. powaking macrumors 6502


    Jul 3, 2008
    Try either RipIt or MDRP to rip the disc first.
  4. dynaflash macrumors 68020

    Mar 27, 2003
  5. The DRis macrumors 6502

    Jun 19, 2010
    Oceanside, CA
    You can also try makeMKV, it's free right now.
  6. MDI, Aug 22, 2012
    Last edited: Aug 22, 2012

    MDI macrumors newbie

    Aug 22, 2012
    Alexandria, VA
    Try this...

    You need to find out which of 99 titles is actually the movie. I found the next paragraph on that explains how to do it.

    Just insert the DVD and let Apple’s DVD Player application play it. Skip through the previews, commercials, and whatever else crops up before you can watch the movie. When the main feature finally begins playing, push your cursor to the top of the display to reveal the menu bar. From that menu bar choose Go -> Title. Scan down the long list of titles and you’ll see a check next to one of the titles. This is the title number of the real main feature. Make a note of it.

    You can now return to HandBrake and instruct it to rip this title as the main feature. All should now be well.

    When you start Handbrake click cancel (don't select a source).
    Click "File", then "Open Source (Title Specific)..., then the box pops up that normally does looking for you to select the source. Select "The Dictator" as you would normally.
    Now another window pops up asking you which title you are looking for. For my copy of "The Dictator", it looks like it's #59. Mine is running at the moment.

    Hope this helps.

  7. jackandjill macrumors newbie

    Oct 11, 2012
    Need to restart Handbrake first

    The above report about opening title 59 works fine as long as you do it as soon as you start handbrake. Fooling around with different methods leaves Handbrake in a state where it cannot open any title. Restarting handbrake and following the procedure worked fine.:)

Share This Page