How To: Get Gmail IMAP Mail and Apple Mail working together nicely.

Discussion in 'iPod touch' started by TheSpaz, Feb 6, 2008.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    This was driving me insane.

    I have IMAP set up on my iPod touch and Apple Mail (in Leopard) kept creating a "Deleted Messages" label even though I wanted my deleted messages to go in the Servers trash, not "Deleted Messages". Here's what you do to fix it.

    I found this website and it saved my day! I'm just sharing it so that people here don't have to go through the same type of thing I did.

    http://5thirtyone.com/archives/862

    Also, there's a tip on how to make the [Gmail] folder disappear. Just go into Settings>Mail>Your Gmail Account>Advanced> Do you see where it says "IMAP Path Prefix"? Just type [Gmail] There and you'll be all set.

    Also, if you found this useful, say thanks so that I know that I'm actually helping people not just talking to myself... hehe.
     
  2. BrownManUPS macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #2
    While I'm sure this is handy, I have quite a different problem:

    My mail doesn't want to sync up all with my iPod. So messages I get on my computer that I haven't wirelessly connected and gotten with my iPod won't go on my iPod...or messages that I have deleted on my touch/mac don't sync up with each other.

    Is it important that both are the same type of box (touch is IMAP by default, and mac is POP)
     
  3. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #3
    Yes, I think you should be using the same type of account on both machines. IMAP is way better than POP in my opinion. Remember, you can still archive your emails locally on your Mac.
     
  4. MurphyM macrumors 6502

    Joined:
    Dec 29, 2007
    #4
    Not sure what you mean here. Are you describing the current situation or the desired situation? Either way, not sure what you mean.

    Also, you say touch is imap by default. You mean when you set it up and you click the big gmail logo? As far as I know that sets you pop. You need to click Other to get imap set up. If you want to see the same stuff on both devices and keep them synced imap is the way to go.

    Spaz - thanks. Nice tip.
     
  5. kresh macrumors 6502a

    kresh

    #5
    Although I'm not having this issue, I wanted to say thanks :)
     
  6. BrownManUPS macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #6
    It's weird, I think when I clicked gmail logo and had a manual setup, it did imap...and then when i asked it to sync "these mailboxes" in itnues, the option was pop. So it seemed to not really sync period because it was two different mailbox types.

    I am trying to convert mail to imap but it is a bitch to do that when you have never deleted mail in your gmail box ever...so it is going to take a while. I'll see if I have any problems after that.

    The desired situation is that my imap on my mac would sync with my touch and my touch imap would sync as well. So like, hence the word "sync"? It didn't do any of this sort of thing before I am experimenting now.
     
  7. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #7
    Yes, in 1.1.3 IMAP is the default Gmail account type when you click Gmail in the Mail Setup Screen.... those of you who are using Mail on a jailbroken 1.1.1-1.1.2 know that POP is the default Gmail account. Also, there's no point in syncing your Mail through iTunes with IMAP because when you make changes on IMAP, it makes the changes on the server and therefore any computer that is setup with IMAP will see those changes instantly.

    Make sure that when you set up Mail, you specify which "labels" you want to use for your Mail. Click on Drafts under [Gmail] and then click the menu Mailboxes>Use This Mailbox For>Drafts and then do that for Trash and Sent.
     
  8. Le Big Mac macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #8
    Thanks. But you know what would be really useful? Would be if google would straighten out their imap configuration so that it wouldn't come out so oddball when used by a standard client like entourage or mail.
     
  9. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #9
    I think it works fine after these adjustments. No problems anymore.
     
  10. BrownManUPS macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #10
    Okay here's my situation:

    I converted my Gmail to IMAP and found like a million messages being downloaded because I didn't delete my messages ever and now the conversations are flowing in. So, before this IMAP switch, i archived the box like you said and then I reloaded the box, but when I did it put it as a folder called "INBOX" under "On My Mac". This set of emails did not appear in the "inbox" button at the top, which is what I want.

    Furthermore, after I deleted all my conversations on Gmail, to start clean, new messages that come in come in under the Inbox at the top, and under All Mail folder in the Gmail tab way at the bottom, and when they are deleted they go to the Trash up at the top but not need to be deleted twice because of a server issue at Google?

    I guess what I'm trying to do is get the All Mail folder in the Gmail tab to show up in the Inbox button above. Any clues?
     
  11. BrownManUPS macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #11
    Bump, does anyone have ideas on this?

    Even on my mac, I hate how I have to delete mails from like 3 different places for them to actually be gone. I HATE iMap and its really getting annoying :(. I think I'll go back to POP3 but I want my iPod to actually sync then...which apparently 1.1.3 uses Gmail iMAP...but perhaps I should just manually do it? Hmmm
     

Share This Page