How to Get iCloud Photo Library Option

Discussion in 'iOS 8' started by nvmarino, Sep 19, 2014.

  1. nvmarino macrumors newbie

    Joined:
    Sep 19, 2014
    #1
    There's a ton of confusion about why some people have the iCloud Photo Library option on their iOS 8 install and some don't. I finally figured it out and thought I'd share to hopefully help clear up the confusion.

    The option will show up if you have logged in to iCloud from Yosemite Beta at least once.

    Now, if someone can please help me understand WTF apple was thinking when they designed iCloud Photo Library, cause I'm definitely still confused there...
     
  2. mpfuchs macrumors regular

    mpfuchs

    Joined:
    Sep 19, 2014
    Location:
    VA
  3. nvmarino thread starter macrumors newbie

    Joined:
    Sep 19, 2014
    #3
    Hmm. To be more specific, when I say "logged in to iCloud" I mean under System Preferences --> iCloud (as opposed to logging in to iCloud.com). Is that what you did? Also, are you running the developer preview or pubic beta? I am running developer preview.

    They way I tested and confirmed logging in to iCloud was what did it:

    I initially did not have the option after updating to iOS 8. A bit of searching around seemed to indicate the option should still be available to developers, and it was obviously available to some people after an OTA update. I was poking around on my mac trying to figure out if maybe I had to do something in Xcode to make it available when I realized I was logged in to iCloud using a different account then the one on my phone. As soon as I logged in on the mac with the same account, boom, the option appeared immediately. To double-check that was what actually did it, I did a factory restore on my iPod and set it up with a brand new Apple ID that I created during the setup process. When setup was finished the option didn't show. As soon as I logged out and back in to iCloud using the new Apple ID it again showed immediately.

    I should also mention that I was running an older version of the Yosemite developer preview when I ran this test.
     
  4. mpfuchs macrumors regular

    mpfuchs

    Joined:
    Sep 19, 2014
    Location:
    VA
    #4
    I'm on the public beta, so that might be the problem.

    Logged in with the same account, but it's a different one than the account I used to get the beta.
     

Share This Page