How to get Mac Pro to stop restarting on it's own?

Discussion in 'Mac Basics and Help' started by Lastmboy, Sep 14, 2014.

  1. Lastmboy macrumors regular

    Joined:
    Jan 16, 2012
    #1
    I have an 18TB hardware raid array where the drives are fine, but the catalog for the drive somehow got corrupted. I get the following message:

    OS X can't repair the disk "TCI."
    You can still open or copy files on the disk, but you can't save changes to files on the disk. Back up the disk and reformat it as soon as you can.


    I've tried every known tool to rebuilt it, but with no success. Therefore, I am attempting to copy everything off of it. However, my problem is that when I start copying data off of it, the Mac restarts itself about every 15 minutes. This makes it a bit painful to copy off 18 TB, when I can only copy about 50GB before it restarts. On restart, I get the message "Your computer was restarted because of a problem.".

    I know it's because of the drive, as this doesn't happen if I disconnect the drive. What I'm wondering is if there is any way to get it to stop restarting (i.e. ignore the catalog errors) long enough for me to get some data copied off. I'm not quite sure why it keeps restarting, other than that it's doing it to attempt to repair the volume. However, after it's auto-reboot, I always get the "OS X can't repair the disk" message. Again, there is nothing wrong with the drives. Appears to just be some data corruption, as some of the files sizes are wrong (unless they started making 255TB drives). Just wondering if there is some way to "suppress" the errors long enough to get the data off it. Thanks.
     
  2. deenamathew macrumors newbie

    Joined:
    Sep 15, 2014
  3. Lastmboy thread starter macrumors regular

    Joined:
    Jan 16, 2012
    #3
    Thanks. I'll give that a try. I should have thought of that, as I've done that on my other Mac for a different issue.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Are you just using Finder to do this file copy? You might try using Carbon Copy Cloner to do the copy (use the free 30 day trial). It uses a tweaked version of rsync and might get past those errors.
     
  5. Lastmboy thread starter macrumors regular

    Joined:
    Jan 16, 2012
    #5
    Thanks. I'll try that. I never thought of using it. I've tried several...
    Path Finder - won't work at all. Says it can't update the source to move the files, even though I try a copy (not a move). Must be a bug in it.
    I've had the best luck with Forklift, although it still restarts on a regular basis. I have to use Beyond Compare (great app that finally has a Mac version) to figure out which files got copied (or partially copied) and which got missed when it restarts. I did try resetting the SMC, but no difference. I'll try Carbon, though. It's worth a try.
     

Share This Page