How to get rid of delete confirmation from Finder

takaiguchi

macrumors member
Original poster
Sep 16, 2014
93
45
I always use the keyboard shortcut "CMD + delete" to delete items. In the past, it hasn't had a "are you sure you want to delete xx" confirmation box, but now it does. Any ideas of how to turn that off?
 

fisherking

macrumors 604
Jul 16, 2010
6,704
1,683
ny somewhere
command-delete sends a file to the trash, and does not delete it...and never did. unless..you had something set up to do that? the default behavior just moves a file TO the trash.

you're talking about files in Finder??
 

takaiguchi

macrumors member
Original poster
Sep 16, 2014
93
45
command-delete sends a file to the trash, and does not delete it...and never did. unless..you had something set up to do that? the default behavior just moves a file TO the trash.

you're talking about files in Finder??
Yep, that's what I mean. Put files in the trash. The dialog box says delete. Here is the image.

 

takaiguchi

macrumors member
Original poster
Sep 16, 2014
93
45
Are you sure that you’re deleting that file from your hard drive? This notification typically comes up for files you attempt to delete from shared hard drives, as these cannot be moved to your trash folder.
From my desktop.
 

jbarley

macrumors 68040
Jul 1, 2006
3,769
1,614
Vancouver Island
I always use the keyboard shortcut "CMD + delete" to delete items. In the past, it hasn't had a "are you sure you want to delete xx" confirmation box, but now it does. Any ideas of how to turn that off?
I just tried your 'cmd+delete' key combo and the action was immediate, file sent from the Finder to the trash, no prompt whatsoever.

Yosemite PB5...

edit:
here is a picture of trying to delete a file from my NAS drive.
Look familiar?
 

Attachments

Last edited:

The19th

macrumors regular
Jul 24, 2014
205
43
NorCal
Another way to test this is if the OP turns off Wi-fi/unplugs ethernet and restarts, then tries to move to trash again. This method can isolate if it's an issue with moving a file from the desktop of the internal storage to the trash, or moving a file from the desktop of a network/shared volume to the trash. If it's the former, then it might be something that needs some troubleshooting.

On GMC3.0 here and moving files from the Desktop (internal storage) to the trash with cmd-delete does not bring up a notification.
 

Tony42187

macrumors newbie
Dec 2, 2017
1
0
I've noticed the exact same problem. I'm assuming that it's because with the new iCloud Drive, any files that you want to delete that are in a iCloud synced folder, those files no longer go to the Trash folder. Since those files are now in a iCloud folder, when you delete them they get deleted permanently right away without going to the trash folder.

On my Mac, I have my Desktop, Documents and Downloads folder included(synced) in my iCloud drive. It's only when I try to delete a file from within these folders is when I get the same popup your getting. But if I try deleting a file that is not within a iCloud synced folder, then I don't get the popup and when I delete a file, the file gets sent to the trash folder.

I always use the keyboard shortcut "CMD + delete" to delete items. In the past, it hasn't had a "are you sure you want to delete xx" confirmation box, but now it does. Any ideas of how to turn that off?
 

macazap

macrumors newbie
Mar 29, 2016
2
0
A little overdue, but here's the answer, as I too prefer keyboard shortcuts for these file management tasks...

On an external drive you will get a delete confirmation message (but not on your OS drive, which under normal default settings sends the file to the Trash).

Cmd+Delete will give you a pop-up message to confirm the file will be deleted immediately.

Press Cmd+D to 'press' the Delete button instead of using the mouse.