Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Marcus263

macrumors regular
Original poster
Jun 16, 2009
119
0
A lot of people, like me might have gotten into a frap after installing OS X Lion, and then finding that SMB and other things are broken. Here is a guide that will help you install Snow Leopard Retail in a VMware Fusion. The EULA has now changed which allows VM to be carried out.

How to install Snow Leopard in Vmware Fusion as a guest OS:

1: Install VMware Fusion

2: Execute Following Code in Terminal:

Code:
sudo bash
cd "/Library/Application Support/VMware Fusion/isoimages"
mkdir original
mv darwin.iso tools-key.pub *.sig original
perl -n -p -e 's/ServerVersion.plist/SystemVersion.plist/g' < original/darwin.iso > darwin.iso
openssl genrsa -out tools-priv.pem 2048
openssl rsa -in tools-priv.pem -pubout -out tools-key.pub
openssl dgst -sha1 -sign tools-priv.pem < darwin.iso > darwin.iso.sig
for A in *.iso ; do openssl dgst -sha1 -sign tools-priv.pem < $A > $A.sig ; done
exit

3: Convert your Mac OS X Install.DMG file to CDR with the following code in terminal:

Code:
hdiutil convert ~/Desktop/'Mac OS X Install.dmg' -format UDTO -o ~/Desktop/'Mac OS X Install.iso'

4: Mount that CDR image and go to terminal once more to type in:

Code:
touch "/Volumes/Mac OS X Install DVD/System/Library/CoreServices/ServerVersion.plist"

5: Unmount the image from Computer so that VMware can access it.

6: Create the OS X Server Virtual Machine but do not start it.

7: Right Click the Virtual Machine you just created, then 'show package contents', from there you are going to edit a file that will force VMware Fusion to boot in BIOS mode. The file extension is *.vmx.

8: Remove/comment out the firmware="efi" line, save and close.

9: Select the CDR image in Fusion and reboot. It should load up nicely.
 

mondomx

macrumors newbie
Jul 28, 2011
1
0
Just sits there with the text spinner, saying "Please wait for the DVD to load..."
The one change i made was making the CDR image read/write because Touch wasn't working, but only after it failing the same way.
 

Nightline

macrumors regular
Oct 22, 2007
107
0
Signal Hill, CA
Seems to be working...

I used the original instructions above, and seems to be working here.

Ended up not working, VMware fusion told me that since it was not a server operating system then it wasn't allowed.
 

Attachments

  • Screen Shot 2011-07-30 at 2.34.46 PM.png
    Screen Shot 2011-07-30 at 2.34.46 PM.png
    136.6 KB · Views: 1,152
Last edited:

blazer125

macrumors newbie
Jul 31, 2011
2
0
error when entering this line

mv darwin.iso tools-key.pub *.sig original

no such file or directory.
 

sergiomcfly

macrumors newbie
Jun 26, 2007
2
0
Automated solution

You could give a try on this application which take care of the whole process. Its a freeware :)

Download here ---> www.goosoft.com/runlion

Obs: This is LION on SNOW LEOPARD

.
 
Last edited:

ArizonaLoco

macrumors newbie
Sep 16, 2011
4
0
Phoenix, AZ U.S.A.
Same problem here

mv darwin.iso tools-key.pub *.sig original

no such file or directory.

I also am receiving this error with my MacBook with 10.7.2 Lion Server.

Search with Spotlight and with system files doesn't yield any file named darwin.iso.

*** Correction

VMware Fusion 4 encapsulates the darwin.iso within the main app.
You can use the terminal commands above but with this location:
cd "/Applications/VMware Fusion.app/Contents/Library/isoimages"

Update:
I have two Mac computers, both with Lion 10.7.2 Server from a clean install. I had Snow Leopard installed in VMware Fusion 3 by doing a special install by manipulating the disc image and such. But after installing VMware Fusion 4 and then using the same SL virtual machine I was unable to successfully use it as before. Every time that I would use it I would need to restore it from a snapshot. Well, that virtual machine was used on a Mac Pro with much more RAM and horse power. My other Mac, a MacBook, just doesn't have those resources. So when I tried to copy the SL virtual machine over and use it there I kept getting messages upon attempts to open it on the MacBook that there wasn't enough RAM and such. So I decided to do the steps above on my MacBook install of VMware Fusion 4 with the Lion 10.7.2 Server that is installed on it. I applied the steps above and when I was done I was prompted to update to the newest update of VMware Fusion 4. That done I had to reapply the steps above. I then proceeded to install Snow Leopard from a DMG I created from my Snow Leopard disc, no manipulation of the DMG. Low and behold, it installed without any issues, it reboots/restarts without issues and I even applied all of the updates. So far so good. I suspect that with each VMware update I will probably need to reapply the steps above. I guess I'll have to wait and see.

Unfortunately for me 4.1.1 breaks this. Any attempt I made to reinstall the OS again resulted in receiving message that the OS is not a server version.

Note that I did not edit the DMG or DVD used for installation.
 
Last edited:

C.Kowalski

macrumors newbie
Feb 5, 2012
23
0
Vienna, AT
This guide works nice even with Fusion version 4.1.3. Only one thing: do not remove the efi-string forcing Fusion to start in BIOS mode. It won't work.
Instead, just let Fusion do its EFI emulation installin Mac OS X Snow Leopard (altough the installation assistant will say "Mac OS X Server").

Greetings.
 

GSilverberg

macrumors newbie
Jan 24, 2013
2
0
Mountain Lion and Fusion 5 now

It's 2013, and I'm on Mountain Lion and my VMware Fusion version is 5. Is anyone still installing Snow Leopard?

I can get SL installed and running, but I'm stuck on one thing.

First, create a Lion or Mountain Lion guest in Fusion.

Then, use Disk Utility in the host to create a new disk image, choose 8.3 GB (DVD+R DL) for size, Mac OS Extended (Journaled) for format, encryption none, partitions CD/DVD, and image format read/write disk image.

Mount this image. Do a "restore" to copy the SL install DVD to mounted image. Eject the SL install DVD, and open Terminal. cd to the mounted image file, cd System, cd Libary, cd CoreServices, sudo touch ServerVerion.plist. Umount the image file.

Go back to Fusion. Create a new OS X guest as OS X 10.6 server, and choose the image file for the installer. Presumably, one of the reasons for using SL is Rosetta, so be sure to install Rosetta. Installation of SL should complete, but it won't boot.

Go to the first Lion/Mountain Lion guest. Add the SL hard drive as the L/ML's second drive and boot. In the guest OS, cd to the second drive (the one with SL on it), cd System, cd Library, cd CoreServices, sudo touch ServerVersion.plist. Shut down the guest OS and remove the second drive (keep the file; do not move it to trash).

Now, the SL guest boots. <-- I'm here.

Changing the darwin.iso file in /Applications/VMware Fusion.app/Contents/Library/isoimages doesn't seem to work. Software Update doesn't work. I downloaded OS X 10.6.8 combo update from Apple and directly tried to apply it, but I get a javascript error. So I'm stuck at SL 10.6 without being able to update.

Sound doesn't work, but that's a driver issue.

Is there more I can do to go further? (I could always create a SL guest on Fusion 2 on an old MacBook, but it's not a self-contained solution.)
 

gilby101

Contributor
Mar 17, 2010
783
363
Tasmania
It's 2013, and I'm on Mountain Lion and my VMware Fusion version is 5. Is anyone still installing Snow Leopard?

....

Is there more I can do to go further? (I could always create a SL guest on Fusion 2 on an old MacBook, but it's not a self-contained solution.)

Have a read of https://forums.macrumors.com/threads/1365439/

Though written for Parallels, the changes required for Fusion are minor. I have used it for Fusion 4 and it should work fine for Fusion 5. The method in this post has two advantages:

1. It does not require changes to anything inside Fusion (or Parallels) - it just makes sure that ServerVersion.plist is always there whenever Fusion checks. So may be more resilient to Fusion updates.

2. There is a clever trick (seems clever to me) in that ServerVersion.plist is removed after the client starts - so that the SL client thinks it is NOT server and so the 10.6.8 combo update works. And puts it back at shutdown so that Fusion thinks it is server version next time the client boots.

Must admit that there is not much left which still requires SL - in my case a few games.
 

Mr. Retrofire

macrumors 603
Mar 2, 2010
5,046
479
www.emiliana.cl/en
...
Then, use Disk Utility in the host to create a new disk image, choose 8.3 GB (DVD+R DL) for size, Mac OS Extended (Journaled) for format, encryption none, partitions CD/DVD, and image format read/write disk image.

Mount this image. Do a "restore" to copy the SL install DVD to mounted image. Eject the SL install DVD, and open Terminal. cd to the mounted image file, cd System, cd Libary, cd CoreServices, sudo touch ServerVerion.plist. Umount the image file.
Why so complicated? Just select the DVD drive (not the volume) in Disk Utility and create a zlib (standard) compressed disk image. Or create a r/w image first, if you edit something on the disk image. Then convert this r/w image in a zlib-compressed image.

Changing the darwin.iso file in /Applications/VMware Fusion.app/Contents/Library/isoimages doesn't seem to work.
Do you shutdown VMware Fusion, before you do that!?

Software Update doesn't work.
If you are an admin in the VM, type this in a Terminal window:
sudo -s

sudo mv /System/Library/CoreServices/ServerVersion.plist /ServerVersion.plist
Then try the software update in the VM. I use the list of found software updates (a screenshot) and go to
http://support.apple.com/downloads/
where i download the necessary updates. I install them in the VM in the correct order. Before i restart the VM, i restore the plist file via:
sudo touch /System/Library/CoreServices/ServerVersion.plist

Sound doesn't work, but that's a driver issue.
More a virtual hardware issue (incompatible virtual audio chip). Zenith has some audio drivers, which work with Leopard, Snow Leopard and Lion guests. See “archive” folder on sourceforge. It is probably useless if you use Lion or Mountain Lion in a VMware Fusion 4 or newer VM, because VMware Fusion 4 or newer supports the Lion and Mountain Lion “HD Audio” drivers (no additional drivers necessary). So you need these “Zenith drivers” only, if you use a Leopard, Snow Leopard or Lion guest in VMware Fusion 3.
 

GSilverberg

macrumors newbie
Jan 24, 2013
2
0
What works with Parallels...

Have a read of https://forums.macrumors.com/threads/1365439/

Though written for Parallels, the changes required for Fusion are minor. I have used it for Fusion 4 and it should work fine for Fusion 5. The method in this post has two advantages:

1. It does not require changes to anything inside Fusion (or Parallels) - it just makes sure that ServerVersion.plist is always there whenever Fusion checks. So may be more resilient to Fusion updates.

2. There is a clever trick (seems clever to me) in that ServerVersion.plist is removed after the client starts - so that the SL client thinks it is NOT server and so the 10.6.8 combo update works. And puts it back at shutdown so that Fusion thinks it is server version next time the client boots.

Must admit that there is not much left which still requires SL - in my case a few games.

Yes, the installation method for Parallels works exactly the same on Fusion, down to the bit about step 1 not working on Mountain Lion. I like the idea of having a script to take care of ServerVersion.plist so it's as mistake-proof as it can get.

If I wanted to resurrect old games, I'd want to go back as far as a System 6 emulator, so games that broke on System 7 could be playable.

My last use for Rosetta in virtualized Snow Leopard was to run Mac the Ripper so I could immortalize a failing DVD.

----------

Why so complicated? Just select the DVD drive (not the volume) in Disk Utility and create a zlib (standard) compressed disk image. Or create a r/w image first, if you edit something on the disk image. Then convert this r/w image in a zlib-compressed image.

The big hint to why so complicated should be obvious to you, if you actually tried to do what you say in Mountain Lion. It doesn't work. You end up with a disk image that's locked. You need Lion or earlier for your prescription to work. So just to make you happy, I made a direct DVD disk image in virtualized Lion. Since you have to install an entire virtualized OS to perform this task, I don't think it's any less complicated.

Do you shutdown VMware Fusion, before you do that!?

Or course. Or more like, is there a reason to try to do this with Fusion running?

More a virtual hardware issue (incompatible virtual audio chip). Zenith has some audio drivers, which work with Leopard, Snow Leopard and Lion guests. See “archive” folder on sourceforge. It is probably useless if you use Lion or Mountain Lion in a VMware Fusion 4 or newer VM, because VMware Fusion 4 or newer supports the Lion and Mountain Lion “HD Audio” drivers (no additional drivers necessary). So you need these “Zenith drivers” only, if you use a Leopard, Snow Leopard or Lion guest in VMware Fusion 3.

I'd say of course it's a driver issue if the driver necessary to make the virtual hardware run. Now, if the virtual hardware were buggy, I'd call it a virtual hardware issue. You don't need any of these hacks to get Lion and Mountain Lion guests running, so it's entirely applicable, since the goal is to get Snow Leopard (and Leopard) guests running.
 

MichaelLAX

macrumors 6502a
Oct 31, 2011
808
18
It is a common Urban Myth that the Snow Leopard EULA prohibits its use in virtualization in Lion or Mt. Lion on a Mac.

Apple sat back quietly while its shills continued to propagate that myth, since it resulted in larger sales of Snow Leopard Server for $499+.

That myth has been largely debunked over the last 18 months; especially by those who have documented workarounds that allowed Parallels and VMWare Fusion to install Snow Leopard client; which Apple was powerless to stop.

Apple finally threw in the towel recently and now offers Snow Leopard Server for $19.99 + sales tax & shipping (call 1.800.MYAPPLE (1.800.692.7753)).

[click on image to enlarge]
 

Attachments

  • Snow Leopard Server order.png
    Snow Leopard Server order.png
    53 KB · Views: 647
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.